Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Cannot Create Blocks


We are using EPiServer 7.5 and suddenly we have got to know that block creation was not possible with the site ("New Block" option is disabled). We suspect this is something to do with database setting/value, but that is not 100% sure.

Mar 13, 2015 21:22

Hi Dan,

if you log in with a administrator account, can that account create blocks? Do you have any block types created in code yet?



Mar 13, 2015 23:21

Thanks Toni for your Reply.

Yea, I'm login with Administrator account and I cannot create blocks. And we do have several block types created in the code as well

Mar 14, 2015 13:00

Hi Dan

Have you tried checking the permissions for the Global Assets folder in admin mode? Someone might of accidentaly removed permissions, particuarly if they were setting permissions from the root:


Mar 14, 2015 17:21

Yes David, permission for "Global Assets" was correctly set

Mar 15, 2015 8:31

In that case I'd suggest checking the following:

  • Try on a different database instance to see if the behaviour is the same
  • Check if the [AllowedTypes] attribute has been set on blocks (or your base block) as this could affect the block availability
  • Check in admin mode if the access level has been applied on a block (Admin > Content Type > Block Types > [Pick a block] > Settings button > Access level). The access level can be set in code but you can see what the access level is set for the block


Mar 15, 2015 15:14

David, I have changed the DB instance and checked. Then it's working fine (I was able to create blocks). Therefore, it's seems to be a DB issue then. So, how could I rectify this DB issue (or how could I figure what  is wrong with the DB)?

Edited, Mar 15, 2015 20:53

One observation is: I can create blocks under "For This Page". But it is not possible to create under "For This Site"

Mar 16, 2015 10:33

Any Help ?

Mar 17, 2015 7:16

If you have removed some rights on the root page, try setting them back and see if it helps.

Mar 17, 2015 7:44

No I didn't remove any rights from the root page.

Mar 17, 2015 9:50

Does the same behaviour happen for pages too? If so then you may want to check if the language has been disabled.

Mar 17, 2015 9:52

If you run with uncompressed javascript-files as described here you can debug and check what happens in EPiServer.Cms.Shell.UI/ (might be another version number for you)

In there is a function called isActionAvailable and some other support functions that is called from that one. If you debug it you might get a clue to what is causing the problem. The function is triggered each time you switch resource location in the assets pane.

Mar 17, 2015 10:29

Hi Dan,

I see from your earlier screenshot that the Global Assets have the enough rights, but what about the children nodes (the "Apply settings to subitems" isn't checked)? Do they have create rights set on them?


Mar 17, 2015 16:18

No this is only happening for Blocks.

I have tested with "Apply settings for subitems" setting. But it didn't work either.

Mar 23, 2015 11:31

Hi Dan

Did you ever get to the bottom of this? If the site is multi-lingual then there is a chance that language permissions may be connected. 

If the site is multi-lingual can you try changing to another language and see if you get the same result?


Mar 30, 2015 12:05

Hello Dan,

We have also encountered the same issue, could you please tell us solution to fix this?


Sep 01, 2015 13:35

Check this post

May 26, 2016 16:11

Check that you don't have an old config settings from EPiserver 7.0/7.1 with site elements that specify global assets root etc

    <site siteId="EPi7Alloy" description="Example Site">
      <siteSettings httpCacheability="Public" httpCacheVaryByCustom="path" httpCacheVaryByParams="id,epslanguage" pageFolderVirtualPathProvider="SitePageFiles" pageRootId="1" pageStartId="4" pageValidateTemplate="false" pageWastebasketId="2" globalBlockFolderId="3" siteBlockFolderId="3" uiShowGlobalizationUserInterface="true" urlRebaseKind="ToRootRelative" siteDisplayName="Alloy" siteUrl="http://lpt-danova02:17002/" uiUrl="~/secretI/CMS/" utilUrl="~/util/" uiEditorCssPaths="~/Static/css/Editor.css" uiSafeHtmlTags="b,i,u,br,em,strong,p,a,img,ol,ul,li" enableXmlRpcHeader="true" />

Its the

globalBlockFolderId="3" siteBlockFolderId="3"

that might generate similar errors like above if they are wrong for an Episerver 7.0 site (and should be removed for a Episerver 7.5 site if you have upgraded it. These settings are stored in database from 7.5+). 

May 26, 2016 16:37

We came across this exact issue today after updating the globalization setting in the web.config from:

    <globalization culture="en-US" uiCulture="en" requestEncoding="utf-8" responseEncoding="utf-8" resourceProviderFactoryType="EPiServer.Framework.Localization.LocalizationServiceResourceProviderFactory, EPiServer.Framework.AspNet" />


    <globalization culture="en-GB" uiCulture="en" requestEncoding="utf-8" responseEncoding="utf-8" resourceProviderFactoryType="EPiServer.Framework.Localization.LocalizationServiceResourceProviderFactory, EPiServer.Framework.AspNet" />

The fix was simply to update the uiCulture attribute to en-GB

    <globalization culture="en-GB" uiCulture="en-GB" requestEncoding="utf-8" responseEncoding="utf-8" resourceProviderFactoryType="EPiServer.Framework.Localization.LocalizationServiceResourceProviderFactory, EPiServer.Framework.AspNet" />
Edited, Feb 14, 2019 16:11

Hi Dan,

Recently I faced this issue in our project. In my case the Language Editing is disabled and because of this I am not able to create new block as well as new page so could you please check if your language editing is enabled or not?


Mar 19, 2019 16:09
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.