Manual workflow on page requiring Publish permissions for the User Group



I have conigired the default out of the box Sequential workflow on the default out of box alloy MVC sample site.

I added a new User to the WebEditors group. I did set the Access Rights for the WebEditors to have "Read, Create, Change, Delete" permissions.

When i try to start the workflow manually , i get get error message "User WebEditors, has not read or publish access for <>> ".

When i give "Publish" permission along with "Read, Create, Change, Delete" permissions for the WebEditors group, it will work.

My understanding was we don't need to have "Publish" rights to trigger Work Flow, because if user got publish permissions he might not trigger workflow and can publish the content directly.

Can you please clarify if "Publish" permissions are mandatory to start a workflow Manually?

Is there an alternative to start workflow manually with out giving "Publish" permissions?



May 12, 2015 0:13

Hi Manohar,

I think you cannot test workflows with only one user / user group, you need two:

- one that creats the content, must not have publish permission, otherwise they can skip the workflow
- one that approves the content, must have publish permission, otherwise they cannot approve the content

May 12, 2015 0:57

Hi Dejan,

I did create 3 different user groups (WebEditior, WebReviewer, WebAdmins) for testing this workflow. The way i want to test is, WebEditor will crate the content and WebReviewer will review & publish the content.

So , I log-in as one of the users from WebEditor group and create a page and try to start the workflow manually. 

The problem is, if the WebEditor group has Publish permissions then only i am able to start the workflow. If the WebEditor group is not given the Publish permissions, i get "User WebEditors, has not read or publish access for <<my page name>> " message and workflow is not started.

I want to know if this is the expected behaviour or a known bug/issue.



May 12, 2015 16:53

If I remember correctly

- First you need to enable workflows in web.config (which you did)
- Create two user groups from admin mode (editors w/o publish permission, and reviewers w/ publish permission)
- Configure workflows in admin mode (set automatic start, who can approve the content, etc.)
- Log in to edit mode as an editor (the one w/o publish permission). When you try to publish the content, you'll see a button called 'Ready to Publish'. Click on it and it should trigger the workflow
- Log in to edit mode as a reviewer (the one w/ publish permission). Click on Tasks, select 'Ready to Publish' from the dropdown list, then select the page you want to approve / reject. When you click on the Publish dropdown, you'll get two options: 'Approve and Publish' and 'Reject Changes'.

May 13, 2015 9:46
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.