Try our conversational search powered by Generative AI!

EPiServer thumbnail service: thumbhandler.axd missing?


I'm trying to get the thumbnail service to work, but I keep getting a 404 on thumbhandler.axd.
Is thumbhandler.axd supposed to be a file on my hard drive? I can't find it.

Jul 21, 2015 9:27

Thumbnail service is a windows service, it can be installed as an optional component when you deploy CMO on site using Deployment Center.

Thumbhandler.axd HTTP handler is added in web.config for CMO UI virtual path when CMO UI is installed on website:

    <location path="EPiServer/CMOUIPath">
            <add name="ThumbnailHandler" verb="*" path="thumbhandler.axd" type="EPiServer.Cmo.Cms.ThumbnailHandler.CmoThumbnailHandler" resourceType="Unspecified" requireAccess="Script" />
Jul 22, 2015 18:53

Right now it is added under:

<location path="episerver/CMO">

However, I installed CMO with a new Alloy site with development center, just to try to get it working. Now, I get a thumbnail, but the thumbnail is a screenshot from an IE error page that says: Navigation to the page was cancled.

I tried to adjust the security options in IE, but it doesn't work. I've also made sure to reserve the service url with urlacl, and made the service log on with my domain user. Still doesn't work, so I'm kinda out of idéas.

Jul 23, 2015 9:08

Try to enable Debug logging for Thumbnail service and see if you get more information about the problem. Edit config file and add something like this:

<appender name="RollingLogFileAppender" type="log4net.Appender.RollingFileAppender">
  <file value="ServiceLog.txt" />
  <lockingModel type="log4net.Appender.FileAppender+MinimalLock" />
  <appendToFile value="true" />
  <rollingStyle value="Date" />
  <datePattern value="yyyyMMdd " />
  <layout type="log4net.Layout.PatternLayout">
    <conversionPattern value="%date [%thread] %-5level %type.%method - %message%newline" />

  <level value="Debug" />
  <appender-ref ref="RollingLogFileAppender" />

Also you can check if this technote is applicable in your case.

But in general, it sounds like IE configuration issue. Can you browse target CMS pages if you run Internet Explorer on the server where Thumbnail service is deployed?

Edited, Jul 27, 2015 11:09
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.