Try our conversational search powered by Generative AI!

Episerver Search Indexing Service: Index not found!


I have set up an Episerver 7.5 site on a new server, and the search is working on the front end, but the error logs show "Reset of index : ' ' failed. Index not found!" when I run the indexcontent service. Below is the error message in full.

2017-07-20 11:48:23,178 [128] ERROR EPiServer.Search.IndexingService.IndexingService: Reset of index: '' failed. Index not found!
2017-07-20 11:48:23,178 [110] ERROR SearchSettings: Could not reset index '' for service uri ''. Message: The remote server returned an error: (500) Internal Server Error. at System.Net.HttpWebRequest.GetResponse()
at EPiServer.Search.RequestHandler.MakeHttpRequest(String url, NamedIndexingServiceElement namedIndexingServiceElement, String method, Stream postData, Action`1 responseHandler)
at EPiServer.Search.RequestHandler.ResetIndex(String namedIndexingService, String namedIndex)

There are also hundreds of errors for images and pdfs like this.

2017-07-20 11:48:51,855 [27] ERROR EPiServer.Search.IndexingService.IndexingService: File for uri 'file:///D:/Websites/MySiteFolder/App_Data/blobs/10c9187b860f4fca87be4836c55fa61e/0bd47e7f6cd6426d93e1253b8342a572.jpg' does not exist
2017-07-20 11:48:51,855 [27] ERROR EPiServer.Search.IndexingService.IndexingService: An exception was thrown when task was invoked by TaskQueue: 'indexing service data uri callback'. The message was: Object reference not set to an instance of an object.. Stacktrace was: at EPiServer.Search.IndexingService.IndexingServiceSettings.SetResponseHeaderStatusCode(Int32 statusCode)
at EPiServer.Search.IndexingService.IndexingServiceHandler.HandleDataUri(SyndicationItem item, NamedIndex namedIndex)
at EPiServer.Search.IndexingService.TaskQueue.Timer_Elapsed(Object sender, ElapsedEventArgs e)

If the index reset is failing, how are there errors caused by the indexing service? Web.config seems normal, WCF is installed on the server, and the correct indexing service domain ( has been added in Episerver admin site settings, the server IIS bindings and host file. 

I've tried to locate the missing blobs to add them back in, but to no avail. Any suggestions on how to fix would be greatly appreciated.

Jul 20, 2017 17:48
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.