SaaS CMS has officially launched! Learn more now.

episerver dies after a short random time, even with an empty project: The program '[14100] iisexpress.exe' has exited with code -1 (0xffffffff).

Vote:
 

I took a new fast laptop (m.2 SSD, 16GB ram, quad core i7 etc) and installed VS (community), latest episerver plugin etc.

I created an empty project, and, via the tutorial, added a page.  I.e. I have folled this, and only this, to the letter (pasting as code as pasting as link causes a 500 from this forum)

https://world.episerver.com/documentation/developer-guides/CMS/getting-started/creating-a-starter-project/

What I see is that after a short random time, episerver dies, and the output in the debug console is:

The program '[14100] iisexpress.exe' has exited with code -1 (0xffffffff).

There are no errors of any sort.

Sometimes this happens before I can view any page, sometimes I can view my page, and even have time to edit it.  i.e. it is dying for no apparent reason anywhere between 0s and 2 minutes after starting the server from within visual studio.

This i a new install of VS, I have never used it before, so will be including the latest episerver and dlls etc.  The version of .net it says its using is 4.7. something.

I have the latest updated windows.  There is very little CPU or memory usage.

Is this normal?

Interetingly when I tried the same thing previously ont he Mac using Virtual box, I observed exactly the same issue with the empty project.  I assumed it was a mac/vm issue,  so went and got a windows laptop instead. But I am seeing the same issue. Neither has had any episerver code or vidusal studio previously installed, nor IIS express. I think I installed IIS and the full version of MSSQL server, but I understand these are not being used (its using the xpress versions which come with VS code)

#209820
Nov 20, 2019 10:27
Vote:
 

Hi John,

It's not normal. I want to confirm your development environment.

Cheers,

Darren

#209889
Edited, Nov 20, 2019 11:29
Vote:
 

1) yes, I folled the "set up a development environment" to the letter.  Twice, on 2 different machines (mac and pc). In both casees I get this error immediatly the first few times I run the project, then it gets better (i.e. takes longer to crash)

2) I am using VS Community (newly installed)

3) I dont really know how to run it as "release". In VS, there is a dropdown at the top where I just changed "Debug" to "Release" and then ran the app (by clickingon the "> IIS Express (google chrome) at the top).  This brings up a dialog: "you are debuggin a reease build".  I choose "stop debugging" and the app stops.  If i select "continue debugging" then it seems to be ok (i.e. not crashed yet, ill try it some more). UPDATE: it crashes also.

4) Sorry, I don tknow how to do this, but the port is different each time I run the app. e.g. its 56300 this time, but last time it was different.

5) Sorry dont know how to run episerver under full IIS vs the built in IIS express.

#209894
Edited, Nov 20, 2019 12:26
Vote:
 

Hey John,

3. To run without Debugging, press Ctrl + F5. Try this first.

4. This URL covers changing ports in IIS Express https://stackoverflow.com/questions/21202885/how-can-i-change-iis-express-port-for-a-site 

5. Dont worry about it for now, should run stable in IIS Express.

#209898
Nov 20, 2019 13:15
Vote:
 

episerver is still crashing. If I change some code, it almost always crashes before the first page is loaded. Then I run it again, and usually then it loads the page, but dies after a minut or two. 

Today created an Alloy project.  Running this I got the same problem. Crashes on first compile, then crashes at a random time after, usually betwen 1 and 5 minutes.

Running with or without debug makes no difference.

The port is different each time I run the app.  The port number doesnt seem to have any bearing on it crashing or not (crashes on 56300. 3000, or what ever else it tries to use.

#210446
Nov 23, 2019 21:46
Vote:
 

I changed the port of iis express following the instructions on that given link (project name, properties, web, change port number, hit "create virtual directory", then ok.

Then I started the one page app again.

It started up on the new IP, but if I go into the CMS tab, and click on a page to edit it, it goes to the old ip still.

Then after a minute or so, it dies with exit code -1 for no apparent reason.

#210447
Nov 23, 2019 21:55
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.