Try our conversational search powered by Generative AI!

Unable to install or update any package through Package manager console


I am unable to update any existing Episerver CMS packages or install new packages like EPiServer.Marketing.Testing through Packages manager console. I am currently using visual studio 2017 and tried restarting Visual studio and also cleared nuget cache. Please have a look at below details of error. Package source is set to 'All' and default project to current project.

PM> Install-Package EPiServer.Marketing.Testing -ProjectName EPIAlloyDemo
Install-Package : Unable to find package 'EPiServer.Marketing.Testing'
At line:1 char:1
+ Install-Package EPiServer.Marketing.Testing -ProjectName EPIAlloyDemo
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Install-Package], Exception
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.InstallPackageCommand

When trying to update CMS to highest minor:

Update-Package EPiServer.CMS -ProjectName EPIAlloyDemo -ToHighestMinor

Attempting to gather dependency information for multiple packages with respect to project 'EPIAlloyDemo', targeting '.NETFramework,Version=v4.6.1'
Update-Package : Package 'EPiServer.CMS' is not found in the following primary source(s): ',C:\Program Files (x86)\Microsoft SDKs\NuGetPackages\'. Please verify all your online package
sources are available (OR) package id, version are specified correctly.
At line:1 char:1
+ Update-Package EPiServer.CMS -ProjectName EPIAlloyDemo -ToHighestMino ...
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : NotSpecified: (:) [Update-Package], Exception
+ FullyQualifiedErrorId : NuGetCmdletUnhandledException,NuGet.PackageManagement.PowerShellCmdlets.UpdatePackageCommand.

Please let me know if i need to make any changes before running these commands or if i am doing anything incorrectly.

Thank you.

Apr 10, 2020 10:50

Hi Ravichandra, 

Please check the Episerver package source does exist in your VS17 or not, if not then go to Tools - Options - NuGet Package Manager - add (+).

And then restart your visual studio and hit the command.


Edited, Apr 10, 2020 17:56
Apr 10, 2020 19:00

I have added EPI server package source later and it worked.

Apr 14, 2020 8:31
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.