Episerver local environment setup



I am trying to configure our client website in my local environment. I have a complete code setup and Episerver database. I am able to connect to the database using SQL.

Am Trying to load the application using Visual Studio IIS Express in my localhost, it is throwing 404 resource can not found error.

I tried URL -- localhost:portnumber/episerver and it gives me below error.

Exception Details: System.SystemException: The trust relationship between the primary domain and the trusted domain failed.

Please help me in setting up my local environment up and running with CMS for my local development and code debugging.

your help much appreciated.

Edited, May 02, 2020 8:15


This issue sounds that you have configured the MultiPlexingMembershipProvider in you web.config. Now if the database is imported from production or some other environment which has Windows domain users from domain like "somedomain/userA" (in the database) and you local environment is in domain "yourcompany" and you don't have access to the "somedomain" then this is what you will see - as the "somedomain" cannot be reached from your environment.

You could locally switch just to use your company domain (swicthing the default membershipprovider to windowsmembership provider and same for role configuration) and you must be member of the local computer administrators to be able to access with you windows credentials. See Episerver configuration documentation about configuring membership and role providers.

If you can't use the above approach, then one way is to delete users having domain login username from database - this way you should be able again to login with your domain account and or SQL membership provider based login.

May 03, 2020 7:18

Hi Antti,

Thank you so much for your reply. Yes production db is imported to our Dev db and I am trying to access the Dev db from local. And also our domain is same. 

And as suggested i tried using windowsmembership provider. Again when I tried login to localhost:port/episerver?ReturnUrl=/episerver

getting the same error.

Server Error in '/' Application.

The trust relationship between the primary domain and the trusted domain failed.

Jun 01, 2020 23:51
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.