SaaS CMS has officially launched! Learn more now.

Assets Pane New Item button disabled for custom type


I created a simple custom type called Authors (just 2 properties, an image and an author bio) and was able to add the type to the Assets Pane by using the pattern in Jacob Jones Alloy Demo Kit -> Locations (my account isn't associated to my company, so I can't post hyperlinks).  It worked great for a while.  I heard from a tester that the New Item button is now disabled.  They can edit existing authors but cannot add new ones. 

The only change we had is that we added an additional site since the type was created and added to the pane.  I'm not sure if that had anything to do with the issue.  The Author type appears on the Assets Pane in both sites.  I checked access rights and the proper roles have rights to create Authors (also they can currently edit them).   I double checked that the type is still in the CreatableTypes array (public override IEnumerable<Type> CreatableTypes => new[] { typeof(AuthorType), typeof(ContentFolder) };).  The Pane shows existing authors that were created before.  

Any ideas on why that New Item button would be disabled?


Mar 02, 2021 17:58

I'd check both the permissions on the assets root node via the permissions manager in adamin. I'd also check the allowed in editor flag on your content types. These have both caused me issues in the past that have presented in similar as the user doesn't have access to create.

Mar 03, 2021 9:07

Thanks Scott! Yeah, permissions was the first thing I checked.  I even overrode the inherited permissions and just granted everything to my type. 

For the allowed in editor flag, is this flag something I need to set on the content type itself for new items to be created in Assets Panel?  I created a tab for the Author type, and it appears in the editor, and already created authors appear under the Authors folder.  But when you click on the folder to add a new author, the New Item button is disabled.  I double-checked that the content type was in the CreatableTypes collection in the ContentRepositoryDescriptor. 

Mar 03, 2021 10:23

Just the allowed in editor flag in the admin for the content type you are trying to create. Usually this should be in code but if it's changed in admin directly it will override. It may seem odd but I've had that happen and it took ages to figure it out. 

Edited, Mar 03, 2021 10:25

I found the where the problem is.  In the NewContent.js file, canExecute is evaluating .isPreferredLanguageAvailable, and for some reason that is evaluating to false for my content type.  My content type doesn't have a language preference.  Any ideas on how to get around this validation?

Mar 03, 2021 17:55

I solved the issue.  Our content tree looked like this:

+ Root

Languages were set up properly on Site 1 and Site 2; however the root had just English checked.  Authors inherited from root.  After changing Root to English, Italian, and German, the New Item button in the Authors tab of the Assets Pane was enabled.  If anyone else has an issue with custom content types in a multisite project, this may be the solution.

Mar 04, 2021 13:01
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.