Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Single Editor Can't Use On-page Edit

Vote:
 

Hi,

We have an issue where one editor can not use On-page edit to edit pages, they have however no problem editing if they switch to the all properties view. If they switch to on-page edit the page renders as it does for visitors or in preview, without the blue borders around fields and content does not become editable when clicking on it.

Here is what we have figured out about this issue and what we tried:

  • This is a problem on all pages for this editor.
  • When other editors edit the same pages they can use on-page edit.
  • The editor says he has never been able to use on-page edit and that he have tried different browser but on-page edit works in none of them.
  • We tried the Reset Views button under the Display Options for that user's profile, it did not help.

The site is using EPiServer.CMS 11.12.0 and EPiServer.CMS.UI 11.20.1

Have anyone seen a problem like this before or have any suggestions on what we can try so the editor can use on-page edit?

#254606
May 10, 2021 7:12
Vote:
 

Can you check what user group he has been added to? (check this link if you don't know how to see usergroup)

If it's different to the user who can edit the pages (as on page editing), then you can add to same usergroup. Please let me know if that don't work.

#254613
May 10, 2021 11:59
Daniel Ekeblad - May 10, 2021 13:52
Hi Praful

Users comes from the customer's Active Directory and there are many roles tied to every user making it difficult to compare them. In the list of assigned roles I find one of the roles mapping to the virtual CmsEditors role. I can't find anything that on page editing has been configured to require special permissions, but I can ask the customer to check if the editor is missing a role that is normally assigned to editors.
- May 13, 2021 11:37
If it is possible, please share one of the user's credential (with which you see the onpage editing is working) to that user and verify if he still facing the same issue or not? Then you will get answer if the issue is with his machine or something with user group/role.
Vote:
 

Does the user have any errors in the browser console?

#254623
May 10, 2021 14:57
Vote:
 

Is it possible for the editor with the problem, to test the computer/browser of an editor without the problem.

Would be nice to rule out anything other than the user account.

#254633
May 10, 2021 17:34
Vote:
 

Sounds like it could be an issue on the users local machine.

Ask them to do the following:

  • Test the feature on a completely different machine, in the latest version of Chrome
  • Try asking them to switch network if that doesn't do the trick
  • Check if they've got any local console errors or network issues in their browser.

To rule out a server-side problem with the user, perhaps you could try resetting their password and logging into their account yourself to see if you can replicate it. 

#254636
May 10, 2021 21:39
Vote:
 

Maybe worth checking if the user has an browser extensions installed that be interferring with the UI

#254637
May 10, 2021 21:47
Vote:
 

Definitely check other browsers and incognito mode if using chromium. Plugins can absolutely interfere with websites and often do.  I once had a Tealium debugger plugin that prevented Google SSO from working.

Also check the user's network traffic to make sure nothing is blocked- make sure they have nothing in their hosts file redirecting traffic, etc.

#254734
May 12, 2021 18:19
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.