Converting to Hyperlink doesn't work for solitary links

Vote:
 

Hi team,

I am facing an issue where a site on EPiServer 7.5 base is hosted on the IIS 8.5 and when I am trying to convert a text to hyperlink to point to an external link, it adds postscript to it (like - :443/EPiServer/CMS/Content/en/,,1417/?epieditmode=False) causing the webpage to show 404 not found when user clicks on it. I believe it's similar to this old thread in the Forum which is marked as resolved but I have already tried the resolution and it doesn't work - 

EPiServer CMS 7.6.3(7.5) Edit mode preview is redirected to 404 on IIS 8.5

If someone has found an alternate solution to this, it would be really helpful.

Thanks.

#280233
Edited, May 12, 2022 17:03
Vote:
 

Can you paste your conversion code? provide more detail?

#280238
May 12, 2022 22:25
Vote:
 

I am using the "Insert\Edit link" UI icon from the Admin backend to try and convert it. In anycase, here is the source code after I tried to convert and  publish it.

<p>&nbsp;</p>
<p>Website<br /><a href="https://www.abcd.com/:443/EPiServer/CMS/Content/en/,,1417/?epieditmode=False" target="_blank" rel="noopener">www.abcd.com</a></p>

#280279
May 13, 2022 10:06
Manoj Kumawat - May 18, 2022 10:35
The link to anchor looks incorrect as you note the port :443 is after forward slash. Which I believe could be a problem. Are you doing that manually?
Prometheus - May 18, 2022 10:40
No, that's the issue. Please check the whole thread. The correct link is "https://www.abcd.com/" . The rest is what gets added automatically by the CMS after I publish the page.
I am trying to understand if there is a workaround or a solution to this problem.
Manoj Kumawat - May 18, 2022 10:53
Do you have any ContentEvents registered on SavingContent/PublishingContent ? The problem looks to me as if some event gets triggered when you publish the page.
Prometheus - May 18, 2022 11:37
I thought so too. However, I haven't and I checked but there don't seem to be any events associated to publishing the content.
It is however, if I add something in front the base URl, then won't add it's own postscript. For example, "https://www.abc.com/Home". the only problem is there is no subpage on the site.
Vote:
 

Razor code showing what you are using the render that link would be more useful.

It will be something like <p>Website<br /> @Html.PropertyFor(m => m.YourLink)</p>

#280280
May 13, 2022 10:20
Prometheus - May 13, 2022 11:30
I am not using a Razor view like that. As I mentioned, my EPiServer version is 7.5 which utilizes .aspx pages. Yet, I am not using any custom pages. The snippet I have shared is from the Admin backend where I have a text block which has a Paragraph for which we can get the HTML source by clicking on the "Source Code" button. In the same content area, we can convert the highlighted text to link using the "Insert\Edit Link" as I mentioned above. Hope that helps.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.