Try our conversational search powered by Generative AI!

Convert many pages with "Convert Pages" tool not working in multi site solution.


I want to convert all pages of type NewsPage to page type ArticlePage.

Since these NewsPages are spread out anywhere in the page tree, I click the checkbox "Convert the selected page and all subpages (of the selected page type)" and the choose the swedish SitePage as starting point for conversion. 

Everything works fine and log tells me that x many pages have been converted.

Here is the problem: When I continue with other SitePages, for instance the estonian I get the message: "Could not convert the page:There are no subpages for the selected page type. The selected root page has page type SitePage.", even though I know that SitePage has many child pages that are of type NewsPage.

Why does the tool only work for the "top most" SitePage beneath Root, and not the others?

Edit: now we made a release to production and the Convert Pages tool does not work as described above on any of the sites.

Edited, Jun 09, 2022 13:35

I have experienced the same problem. Try changing from-pagetype og to-pagetype, and try again. 
Changing the pagetype options, and then changing them back again, usually does the trick!

I just tested on 11.20.6 and were able to both reproduce the issue, and work around it by changing the values as described above.

Edited, Jun 10, 2022 22:29

Hello, I am sorry I didn't follow the "Try changing from-pagetype og to-pagetype". I tried changing the from and to types to other types a and then back, but that didn't work.

Jun 13, 2022 9:11

Try updating to Episerver.CMS.UI 11.36.10 (released today), and see if that fixes your issue?

Edited, Aug 02, 2022 15:00

Hi Hannes!
Which version of CMS UI do you use?
I tried with CMS UI 11.36.10 and 11.27.0 but I cannot reproduce the issue you described. I guess I didn't have the right steps to reproduce.
Can you write down the steps you've done and also the simplest tree structure of your sites?

Aug 04, 2022 14:50

Maybe the issue is related with languages not with the multisite? A while ago there was a fix for it:

Fix for CMS 11

and for CMS 12:

Aug 08, 2022 8:52

I have updated to episerver cms ui 11.36.10 and it still does not work.

Aug 18, 2022 12:01
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.