Try our conversational search powered by Generative AI!

Error when opening the "Catalog" addon in CMS


So we have two machines, both running the same code, and they uses the same database(s) and they both point to the same appdata folder.

On one machine (my own computer), the Catalog in CMS works fine, but on our test machine, we get a script error when starting it, so it will not work at all, this happens on the URL '/episerver/Commerce/Catalog' line 67, where the function parser.parse() is called. What can possibly be wrong here cause I am sure there is some error somewhere on the server or related, but there is nothing apart from this crypptic dojo error. So everything else works perfectly fine, even using catalog items (ex. products) as blocks and editing them after they have been placed, tis just the "Catalog" (that has the link above) that throws this error.

  1. dojo/parser::parse() error Error {stack: "Error: Could not resolve dependency "epi.storeregi…ll/3.0.1209/ClientResources/dojo/parser.js:2:8935", message: "Could not resolve dependency "epi.storeregistry" (epi.dependency)"} parser.js:2
    1. (anonymous function)parser.js:2
    2. then._2f6.thendojo.js:3776
    3. lang.extend.otherwisedojo.js:3873
    4. _1b.parseparser.js:2
    5. (anonymous function)Catalog:67
    6. (anonymous function)dojo.js:713
    7. _1a._1c.(anonymous function)._1c.(anonymous function)load-css.js:2
Feb 19, 2014 14:58

Forgot version numbers, everything installed from the latest version available in nuget feed, there are no updates available for any of the relevant addons either:

  <package id="EPiServer.CMS.Core" version="7.5.1002.0" targetFramework="net45" />
  <package id="EPiServer.CMS.UI" version="7.5.446.0" targetFramework="net45" />
  <package id="EPiServer.Commerce" version="7.5.1000.0" targetFramework="net45" />
  <package id="EPiServer.CommonFramework" version="7.5.446.1" targetFramework="net45" />
  <package id="EPiServer.Framework" version="7.5.1002.0" targetFramework="net45" />
  <package id="EPiServer.Search" version="7.5.446.0" targetFramework="net45" />

Feb 19, 2014 15:08

I'm experiencing the exact same thing here on one of our development machines :(

Feb 24, 2014 12:50

I manged to solve it (sort of), by completely wiping the site root of the dev machine and deploying everything again. Only thing I can think of is that there was a wrong version of a dll in the "modulesbin" folder, but I am not 100% sure what exactly solved the problem (or what the problem even was in the first place).

Feb 24, 2014 12:59

We saw the same issue on a developer machine that did not have EPiServer installed in "C:\Program Files\..."

Feb 24, 2014 14:59

Hmm, that might be related. The machine did indeed lack the Episerver commerce module installation in program files at one point (it had episerver installed). Though it still showed the same error after installing the commerce module installer, might have been a combination of issues.

Feb 24, 2014 15:13
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.