SaaS CMS has officially launched! Learn more now.

Can't move category node in admin


I have imported a tree pf categories to EPiServer using the ContentRepository API. The nodes have the type "Default Catalog Node".

Everything seems fine about them, but when I try to move them I get the message "One or more of the items has a content type which is not allowed at the destination.". I've tried both moving it to other categories and to the catalog. And it doesn't matter if I use cut/paste or drag/drop.

Anyone has any idea what the problem can be?

Feb 02, 2015 11:28

What Commerce version do you have installed? I've seen similar errors, but with users dragging pages instead of category nodes. What errors do you get logged in Firebug/Developer Tools when dragging and dropping?

Feb 04, 2015 0:43

It makes a call to: /EPiServer/cms/Stores/contenttype/?query=getavailablecontenttypes&parentReference=1073741900__CatalogContent
With the response:
{}&&[{"id":18,"guid":"87568f45-243b-453d-9ea0-72880060080b","name":"EntryPromotion","localizedName":"EntryPromotion","description":null,"localizedDescription":null,"imagePath":null,"groupName":null,"availableContentTypes":[],"typeIdentifier":""},{"id":16,"guid":"3dc1f92e-6c1f-41e0-8c44-303782b3f641","name":"CampaignData","localizedName":"Campaign","description":null,"localizedDescription":null,"imagePath":null,"groupName":null,"availableContentTypes":[18,16,19,22,23,20,21,11],"typeIdentifier":"episerver.core.campaigndata"},{"id":19,"guid":"74ff8b32-0353-456b-bd82-b90b125c4446","name":"OrderPromotion","localizedName":"OrderPromotion","description":null,"localizedDescription":null,"imagePath":null,"groupName":null,"availableContentTypes":[],"typeIdentifier":""},{"id":22,"guid":"055191c5-fc5e-41cc-8104-d21756be3035","name":"Start","localizedName":"Start","description":"","localizedDescription":"","imagePath":null,"groupName":null,"availableContentTypes":[18,16,19,22,23,20,21,11],"typeIdentifier":"shop.models.start"},{"id":23,"guid":"356a652a-bd06-45d1-8090-48c18bbdcdf8","name":"Category","localizedName":"Category","description":null,"localizedDescription":null,"imagePath":null,"groupName":null,"availableContentTypes":[18,16,19,22,23,20,21],"typeIdentifier":"shop.models.category"},{"id":20,"guid":"e820561c-e6e0-4306-9bbb-8e18d081ea11","name":"SalesCampaign","localizedName":"Sales campaign","description":null,"localizedDescription":null,"imagePath":null,"groupName":null,"availableContentTypes":[],"typeIdentifier":""},{"id":21,"guid":"7e9290e7-7c88-4f97-bd7d-9e698cb4cd0e","name":"ShippingPromotion","localizedName":"ShippingPromotion","description":null,"localizedDescription":null,"imagePath":null,"groupName":null,"availableContentTypes":[],"typeIdentifier":""}]

It however works if I import a subclass to NodeContent instead of NodeContent...

Feb 04, 2015 9:58


I have a recent version of EPiServer.Commerce and I got the same problem:
EPiServer.CMS.Core (11.14.0)
EPiServer.CMS.UI (11.23.1)
EPiServer.Commerce (13.14.1)

If I copy/cut then paste any variant from one product to another product I have the same following error popup:
"One or more of the items has a content type which is not allowed at the destination."

Note if I do it on any product without a variant it works fine but if it has a variant child selected I got the same error message.

Did you eventually manage to fix or workaround that issue ?

Thank you,

Edited, Feb 12, 2020 15:04

I actually found and resolved our issue, the Commerce project we have here override the Commerce types and the one for the Category (NodeContent) was including a content type restriction without the Variant type inside (ie. attibute [...] AvailableContentTypes(Include = new[] [...] ).

The Variant type is needed in this restriction list because when you duplicate a Variant it is first added to the Category then you can link it back to the Product you want.

Edited, Feb 12, 2020 16:08
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.