Try our conversational search powered by Generative AI!

Catalog Promotion Not working


I am trying to create a promotion at catalog level. For example anything (any product) in my catalog Apparal -> Dresses, should get a 50% discount. 

I tried ceating a Promotion as "Catalog Entry: Build Your Own Discount"


TargetLineItem.CatalogEntryId - Equals (Text) - Dresses 


TargetLineItem.CatalogEntryId - Equals (Text) - Apparal-Dresses 

I tried Equal and contains. But  neither worked.

Any suggestions, on if this works out of the box in episerver?

May 27, 2015 21:24

Which version are you on? Promotions are applied in a workflow and workflows are disabled by default since update 40. See if you need to enable them. Or do you have other promotions that works?

May 27, 2015 22:24

We are on Episerver Commerce 8.0 Version. And th eOther Promotions work fine. 

May 27, 2015 22:28

Hello Sapna

In the example you supply then you can try: SubmitTargetLineItem.CatalogNode - Contains - "Apparal-Dresses"


May 27, 2015 23:02

Hi DAvid! 

Thanks for the response. I tried that, but that didn't work either.

May 27, 2015 23:08

Hello Sapna

That configuration should work, I use it myself to discount some items by 20% that are linked to a "20% off" category.

Can you check the promotion itself hasn't expired and is marked as active, also can you check that the campaign you are associating it with also hasn't expired and is marked as active?


May 27, 2015 23:28

For info I have included some screenshots of the promotion config and the catalog node I refer to:

May 27, 2015 23:36

Hello Sapna, did the suggestionn above resolve your issue?

May 28, 2015 12:06

The suggestion from David should work, however due to a bug in our workflow, you'll need to update to latest version (8.12) to make the promotions work with CatalogNode code.



May 28, 2015 13:31

Hello David. 

I had my promotion configured like that. but it didn't work for me.

May 28, 2015 16:18

Hi Quan,

We are on 8.11 version. I ll try to upgrade to 8.12 and see if that fixes the issue.

Thank you all for the responses. I will post here once my issue is fixed and the solution that fixed it. 

Thanks everyone!!

May 28, 2015 16:23

Hi Quan,

We upgraded to Episerver.commerce version 8.13. 

After upgrade I tried creating a new promotion of type "Catalog Entry: Build Your Own Discount". And configured it in similar way as David suggested. Unfortunately I am not able post or copy any images or screenshot here. 

It didn't work though. Guys any thing else that I am missing.

Jun 15, 2015 23:10

This is the setting from our reference site, and I can say it's working :) 

Jun 16, 2015 9:22

Oh I am sorry guys! I just heard from the team, we did not upgrade the commerce manager yet. That probably could be the reason. Will test it again later. Thanks!

Jun 16, 2015 17:09

If you updated the front-end and it does not work then it might be a probem, regardless of you upgraded CM or not - but I suggest to create a promotion like above to make sure it works for you.



Jun 16, 2015 17:18

I do have it configured same way. Here is the screen shot. (Finally I am able to attache the image)

Image 1:

Image 2:

Jun 16, 2015 18:09

In my configuration above, I have tried making it work without the Coupon code (which is coupon applies automatically without entering the code). That didn't  work either.

Jun 16, 2015 18:11


My promotions are still not working. I have attached the screen shot above. Does anything look wrong with the configuration. We also recently updated our episerver to 8.13.0 version. Both front end and commerce manager.

Jun 23, 2015 22:39


Does any other promotion works for you?

Did you try with a campaign for all market? 

And do you have custom workflow? because the bug I mentioned above was fixed in Mediachase.Commerce.Workflow.dll.



Jun 24, 2015 13:42

Hi Quan!

Yes other promotions work for me. And this promotion is assigned a campaign that has all the markets assigned, is active, and the start date and exipre dates are in current range for this campaign and promotion.

Yes we do have workflows customised. But I think we have added new activities to the CartValidate workflow and CartPrepare workflow. We have not modified any of the existing activities. Do you think we should upgrade our workflow project to the latest version as well? Would that help?


Edited, Jun 24, 2015 15:32

That's the problem. CalculateDiscountsActivity.cs/CreatePromotionEntryFromLineItem method, this line 

            Entry entry = CatalogContext.Current.GetCatalogEntry(lineItem.Code, new CatalogEntryResponseGroup(CatalogEntryResponseGroup.ResponseGroup.Variation));

Should be changed to

            Entry entry = CatalogContext.Current.GetCatalogEntry(lineItem.Code, new CatalogEntryResponseGroup(CatalogEntryResponseGroup.ResponseGroup.Nodes));

Build it and check if it works for you.



Jun 24, 2015 16:40

Thanks Quan! 

So for testing purpose, I unplugged my customised workflow and referenced to the Mediachase.Commerce.Workflow from the config file.

Gosh.. It still didn't work. What else could be the reason. 

Dot net reflector shows I have this code in CalculateDiscountsActivity.cs/CreatePromotionEntryFromLineItem method

Entry entry = CatalogContext.Current.GetCatalogEntry(lineItem.Code, new CatalogEntryResponseGroup(CatalogEntryResponseGroup.ResponseGroup.Nodes));

Why is it not working. uhhh...!!

Jun 25, 2015 19:26


In this case I would suggest to contact our support service - that would be the best way to solve this issue.



Jun 25, 2015 20:58

I know this is an old post.... but if its any use for anyone who has been in the same position as me

I'm using Commerce 9.20 and the latest workflows for commerce 9.19+

I had exactly the same issue, however I solved it by change the node.ID -> node.Name

if (String.IsNullOrEmpty(catalogNodes))
  catalogNodes = node.Name;
  catalogNodes += ";" + node.Name;

This fixed the issue for me and now promotions can be set by category using exactly the method suggested by David and Quan above.

Sep 02, 2016 15:25
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.