Try our conversational search powered by Generative AI!

Could not find stored procedure 'mdpsp_avto_CatalogNode_Get'.



When trying to navigate through catalog after importing I get YSOD with the message:

Could not find stored procedure 'mdpsp_avto_CatalogNode_Get'.

This results in dojo error 500 that gets stuck in 'opening' catalog node in the UI manager extension for CMS, although that worked till last Friday.

I was fiddeling with the content last week in order to get the full understanding how thing were working and every time I could navigate through the catalog structure. 

Since YSOC I have also tried to upgrade nugets for epi commerce and did updata-epidatabase yet that procedure is still not present in the commerce DB. I susptect that even finding the body of procedure and scripting it into DB will just fix that issue and that the next one will emerge.

Should I run some nuget to restore this missing stored procedure?

Oct 30, 2017 10:55

It should not call to that stored procedure, as it should not even exist. I don't know what happened to your database, but I suspect it is in bad state.

One thing you can do is to run this 

Exec mdpsp_sys_CreateMetaClassProcedureAll

in SQL Server Management Studio to recreate all stored procedures used by MetaDataPlus. But that might not solve your problem if you have faulty metaclass/metafield definition. 

Oct 30, 2017 13:02

Yes, I suspect that it's the later case.

Oct 30, 2017 16:25
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.