Try our conversational search powered by Generative AI!

MetaField stuck in Commerce UI


I was recently tasked with cleaning up unused properties and unused MetaFields in our Epi Application.  I am running into an issue where I have performed all of the removal/cleanup steps for a MetaField (as far as I know) yet the field is still visible in the content tab in the Epi Commerce Catalog UI.

So let's say the task was "We need to remove MetaFieldX" and here are the steps I took to remove it:

1 - Removed the code associated with MetaFieldX in our codebase

2 - Deployed the changes to our test environment

3 - Logged into the Commerce Manager, and unlinked MetaFieldX from all of it's usages throughout our Meta Classes, and clicked OK to save the changes.

4 - In the Commerce Manager, I went to MetaFields and located MetaFieldX.  When I clicked it, a delete button becames present (which to my knowledge only appears when it's associations are completely unlinked as completed in my previous step)

5 - I clicked delete to delete MetaFieldX and it no longer shows up in the Meta Fields section in Commerce Manager.

6 - I logged in to our Episerver cms console and navigated to Commercer -> Catalog - > random sku (Based off Entry Content)

7 - I see MetaFieldX listed in the Content tab still.  I am convinced it does not function even if I provide a value because the code is removed anyway.

I am wondering what additional steps need to be taken to have MetaFieldX removed from the UI?

Below are the Episerver package versions I am using

  <package id="EPiServer.CMS" version="10.10.1" targetFramework="net47" />
  <package id="EPiServer.CMS.Core" version="10.10.4" targetFramework="net47" />
  <package id="EPiServer.CMS.UI" version="10.10.2" targetFramework="net47" />
  <package id="EPiServer.CMS.UI.Core" version="10.10.2" targetFramework="net47" />
  <package id="EPiServer.Commerce" version="10.8.0" targetFramework="net47" />
  <package id="EPiServer.Commerce.Core" version="10.8.0" targetFramework="net47" />
  <package id="EPiServer.Commerce.FindSearchProvider" version="8.14.3" targetFramework="net47" />
  <package id="EPiServer.Commerce.UI" version="10.8.0" targetFramework="net47" />
  <package id="EPiServer.Commerce.UI.ManagerIntegration" version="10.8.0" targetFramework="net47" />

Mar 15, 2021 18:52

This has been solved.

Turns out, in addition to these steps clearing and then re-running the find index takes care of this

Mar 15, 2021 23:04

For me, I've tried unlinking the MetaField and expecting it to be removed from the product page, instead, it's displaying the property name instead even after doing a reindex.

I did an IIS reset and the unused property is now gone. 

Jul 29, 2021 6:03
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.