Try our conversational search powered by Generative AI!

Not seeing Left Menu in Commerce Manager with Azure AD login



We've setup Commerce manager to work with Azure AD login on DXP environments. We got past login successfully, but got Access Denied screen. We mapped CommerceAdmins role to the WebAdmins role defined in Azure AD and we added CommerceAdmins as a group under Permissions For functions. Now we got past Access Denied screen and can see the Commerce Manager User Interface. The left menu, however, only shows Tabs and no links under it to get to any page :

Here's the web.config Virtual Roles section :

<virtualRoles addClaims="true">
          <add name="Administrators" type="EPiServer.Security.WindowsAdministratorsRole, EPiServer.Framework" />
          <add name="Everyone" type="EPiServer.Security.EveryoneRole, EPiServer.Framework" />
          <add name="Authenticated" type="EPiServer.Security.AuthenticatedRole, EPiServer.Framework" />
          <add name="Anonymous" type="EPiServer.Security.AnonymousRole, EPiServer.Framework" />
          <add name="CmsAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="SecGrp-Episerver-Integration-WebAdmins, SecGrp-Episerver-Integration-ThirdPartyDevs" mode="Any" />
          <add name="CmsEditors" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="SecGrp-Episerver-Integration-WebAdmins, SecGrp-Episerver-Integration-WebEditors, SecGrp-Episerver-Integration-ThirdPartyDevs" mode="Any" />
          <add name="Creator" type="EPiServer.Security.CreatorRole, EPiServer" />
          <add name="SearchAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="SecGrp-Episerver-Integration-WebAdmins, SecGrp-Episerver-Integration-ThirdPartyDevs" mode="Any" />
          <add name="SalesOpsAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="SecGrp-Episerver-SalesOps, SecGrp-Episerver-Integration-WebAdmins, SecGrp-Episerver-Integration-ThirdPartyDevs, SecGrp-Episerver-CMP-Global-Marketing" mode="Any" />
          <add name="CommerceAdmins" type="EPiServer.Security.MappedRole, EPiServer.Framework" roles="SecGrp-Episerver-Integration-WebAdmins, SecGrp-Episerver-Integration-ThirdPartyDevs" mode="Any" />

What am I missing thats causing the left menu to not show? In Permissions For Functions, do I need to add CommerceAdmins group or SecGrp-Episerver-Integration-WebAdmins, SecGrp-Episerver-Integration-ThirdPartyDevs?

Please advice.



Jul 12, 2021 22:38

Hi @Ritu

Sigh this is always an annoying one. Could you try re-extracting the Apps folder from the CommerceManager nuget package and copy them back int your Commerce Manager project.

If that doesn't help then try navigate to this link: <yourcommercemanagerroot>/Apps/Shell/Pages/ContentFrame.aspx?_a=Customization&_v=LeftMenuItem-List

That's the left hand admin url that allows you to set permissions for each menu item. See if anything is out of the ordinary there.

Jul 15, 2021 12:24

Hi Surjit

I copied over the Apps folders again from nuget package folder and reviewed permissions on the link you shared. Most of the permissions are already mapped to Commerceadmins role. I even mapped the Azure AD SecGrp-webamin role to these now and restarted the site but still no luck :

So not sure what else is wrong here.

This works fine on my local where Commerce Manager is tied to SQL Login. But not on INTE where its tied to Azure AD login. I'm inclined to assume its because of the access/permissions on the Azure AD roles/groups.




Jul 15, 2021 15:19

Ritu, Can you check permissions have been added for the following functions:

  • core:mng:leftmenu
  • markets:tabviewpermission
  • order:tabviewpermission
  • catalog:tabviewpermission
Jul 15, 2021 20:29

I assume you have added the Azure AD roles to both configs? Site and Commerce Manager

Jul 23, 2021 13:33

Hi Jeroen

Yes the AD roles are setup for both site and Commerce Manager.

And to answer Surjit's questions above, I did double check all permissions, mapped CommerceAdmins and the AD roles to all that had it missing under Permissions for Functions, redeployed code for commerce Manager, but still no luck. I can access pages, if I type in the URL directly, but don't see left menu links.

Example, I'm at the Order Meta Field page, but no left menu links :

Jul 23, 2021 13:42

Couple more suggestions.

1) Make sure all you're nuget packages are up to date across all your projects.

2) Do you get the same issue if you login as a user with a 'Administrator' role?

3) Before you deploy to Inte DXP. Use kudu to delete the site in the current live slot. If you're using the Deployment API, it will upload your deploy packages to the free slot which im sure should be empty by default. This is just to double check you're deploying a clean version to the site.

Jul 25, 2021 20:54
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.