The trust relationship between the primary domain and the trusted domain failed.

Hi. I'm currently working on a console application, and trying to get the episerver webservices to work(DataFactoryService.asmx) I've done what the webservices tech note says, to configure episerver to allow others to use the webservices. IIS edit, base authentication. Webconfig has been editted with new webservices: and httpmodulle key added. According to the tech note this should be okay, and now I would be able to run. When i try to connect to http://localhost/webservices/dataFactoryService.asmx to test it, I get prompted for the username and password. I write the correct data localmachinename\MyWebServiceUser xxxxxxxxx And then I get this exception. The trust relationship between the primary domain and the trusted domain failed. I have tried to run with other users, the one I normally use to connect to my company AD. tried google for info, but still the same problem. Have anyone had similar problems, and how did you resolve it? Thanks. Savo
Dec 18, 2006 13:02
Are you running .NET 2.0? If so, this indicates that the you have some problems with trusts between domains in your AD. If one of the domains are down, you might see this. I guess there are other things that could lead to this error too. Can you log in to your site (using standard forms authentication) using your windows user? /Steve
Dec 19, 2006 0:40
Hi thanks for the quick reply. Well, I didn't try with my domain user before, but as I try to login in EPiServer(Forms auth) now, with my domain user, I see the same trust relationship error. EPiServer is running as a dev server on my computer, and the Primary Domain controller is up, as I'm connecting to it with my user on windows login. I've read that taken my computer off the domain, and back again could solve the problem. I'll try when I get hold of an admin.
Dec 19, 2006 10:39
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.