FriendlyUrl problem - not appropriated url structure

Hi, I was working on enabling friendlyUrl functionality on 'old' solution. I'll cover here what problem I encountered and how it was solved. First of all I added required code: To web.config 1. 2. As well as to header.ascx: 1. After that friendlyUrls were not working like I suppose them to. After some investigations and Steve C. help, it appeared that url structure was a previous attempted on making search engine friendly urls. Example url was: and should be: To solve it follow those steps: 1. Change back to the "interactive use" type of urls as shown in screenshot below. 2. Then "Rebuild" all addresses. This will update all the urls to all pages in the database. Keep the settings as shown below. After done this, whenever you surf to a page on the site, it should show the urls in the "page.aspx?id=1234" style. Then, try to turn on the friendly urls again (on Manage Web Addresses), and see if it works.
Jan 23, 2007 22:51
Wow, it worked! I wish I had searched here for a solution to this problem _before_ spending a couple of hours trying to solve it... :) Thanks! /Patrik
Jun 12, 2007 16:07
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.