SaaS CMS has officially launched! Learn more now.

Flash (flv) player does not work in episerver

My client has requested we add stop and play buttons into the flash movies on their site. We chose use the in built .flv player function in flash 8 to add the control skin (SteelExternalAll.swf) to the movie. This .swf must exist in the same location as the served page in order to work, but the stop, play control swf does not show when published in episerver. I have tried adding this .swf into the root, templates directory and units directory, but each time this fails. does anyone have any ideas how to get this working? Ben
Apr 03, 2007 5:13
I guess you've tried to put the control swf file in the same folder as the player/movie? If the Flash content is served from /assets/flash/ I guess the control should be located there as well. Try to Google your problem, I guess you can find a good answer there, for example this one? Good luck!
Apr 03, 2007 16:07
FLVs also needs to have the MIME type set up in your IIS /jesper snive
Apr 05, 2007 14:02

Im having exactly the same problem Ben.  Did you manage to find a fix for the issue?

The weird thing is that if I preview the movie .swf file from the file browser popup I can see the video playing normally WITH the control buttons so it is correctly picking up the 'SteelExternakAll.swf' file as well as the .flv file which are all located in the same directory yet when I add the .swf file in to any of my episerver pages I lose the control buttons again...

May 08, 2008 5:41

I've got a similar problem.

At first, I couldn't even see my index.swf but after I put all swf and flv files in the same directory(root) I could finally see the flash. Unfortunatly the flv doesn't show. Only to background image.

Does anyone know why and have a good sollution??? 

Edited, Jun 04, 2008 15:47
As said above, you need to add the .flv-extension as a mime-type(video/x-flv) in your IIS.
Jun 05, 2008 9:50

Has somebody managed to get a video to play with JW flv player in Episerver?

With the embeded code I get the player to show but the video dosent start.
The mime type is OK
The wideo is in Adobe FMS3 and it plays ok from other webpages but not from Epipage.

Please help


Jun 19, 2008 20:22

I have fixed this successfully & thought I'd share my solution.


In your Global.asax:

 <%@ Application Language="C#" Inherits="EPiServer.Global" %>


<script RunAt="server">


    protected void Application_BeginRequest(Object sender, EventArgs e)





    /// <summary>

    /// EPiserver's virtual paths pose a problem for Flash video. The video file can load

    /// fine, but it references a second Flash file which holds the controls, and looks for that

    /// in the same location as the current page, which does not have the controls file.

    /// </summary>

    protected void HandleRequestForFlashPlayerControls()


        string FlashPlayerControlsFileName = System.Configuration.ConfigurationManager.AppSettings["FlashPlayerControlsFileName"];


        string FlashPlayerControlsLocation = System.Configuration.ConfigurationManager.AppSettings["FlashPlayerControlsLocation"];


        if (Request.Url.PathAndQuery.Contains(FlashPlayerControlsFileName) &&

            !Request.Url.PathAndQuery.Contains(FlashPlayerControlsLocation.Replace("~", "")))








And in web.config, add some appSettings:

 <add key="FlashPlayerControlsFileName" value="SteelExternalAll.swf"/>

<add key="FlashPlayerControlsLocation" value="~/Documents/Media/SteelExternalAll.swf"/>

 The setting "FlashPlayerControlsFileName" is the name of your Flash Player Controls file. "FlashPlayerControlsLocation" is the path to this in EPiServer.


Enjoy Smile 

Jun 20, 2009 10:42


But where to add that code?


// jake

Jun 24, 2009 17:36

Your Visual Studio project should have a Global.asax file. If it does not, you can add one. If you have a Global.asax.cs, you can also add the code within the <script> tag into there.

Global.asax is where you can handle global events in ASP.NET, such as Application_BeginRequest which fires on every http request handled by ASP.NET.


Jun 24, 2009 22:21
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.