Try our conversational search powered by Generative AI!

File Manager - Create New Version bug


Our users are getting the following error occasionally when updating files in file manager.

They open file manager, right click a file and check it out then right click again and select  'create new version', they select a file and click save and get the following error:

"Failed to add relation from [GUID] to [GUID] in object store localdatabase."

The workaround is to delete the file, then go through and update all the references but obivously with lots of references this is a pain.

We are using 5  R2 sp1,




Jun 22, 2009 13:24
Can anyone help with this?
Jun 26, 2009 10:36

This is still causing us headaches, is there any resolution to it?




Jul 21, 2009 15:09

I've found this, but I'm not sure if it's the resolution we need:

 EPiServer file systems in CMS 5 are by default Versioned file system and store the files in a GUID structure in your VPP folder, and the real structure is stored in EPiServer object store.

When the versioned file system gets corrupted on a certain node it’s not possible to manage the files below that node therefore a has written a bit of code that by pass the file system and creates unified file system objects for the structure based on how object store looks like Create versioned file system objects from a file structure .

Exception Failed to add relation from <guid> to <guid> in object store localdatabase.

After a migration from EPiServer 4 to CMS 5 i get this error, and one way to create a workaround is to modify the script "Create versioned file system objects from a file structure " so it move all files to a new structure.



Jul 22, 2009 10:30

Hi Jon,

Have you tried giving setting bypassAccessCheck="true" under virtualPath -> Providers ??


Aug 14, 2009 12:00


I've had a similar problem upgrading from R1 to R2.  Some of the files were corrupted (version counter = 0).  This was not a problem in R1, but caused the File Browser to crash in R2.

If you can verify that the files that are causing the problem have a versioncounter of zero, then you can write a .net script to run through all the files and then you can do the following check:

Asset = VirtualPathHandler.Instance.GetFile(Server.UrlDecode(f.VirtualPath), true) as UnifiedFile;
n = Asset.Length;

string s = Asset.Summary.Comments;
catch (Exception)


If an exception is raised, then something is wrong with the file.  This is a bit crude, but worked for me.





Aug 14, 2009 12:19
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.