Problem when deploying site. Only get white page


So our site has reached the point when it's time to put it out for testing on a subdomain. I've taken the steps that Frederik Vig mentions in his blog besides the part where he uses Unleash It to copy the files needed. Instead I just put a copy of the entire project folder on to the server.

I followed the rest without any problems to it and when I test the site I only get a white page containing:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<META content="text/html; charset=windows-1252" http-equiv=Content-Type></HEAD>

I can reach ApplicationInitializing.txt from it so the subdomain seems to be set up correctly. Any ideas of what causes the problem? Is it because I didn't use a publisher to do copy the files? I don't see the difference. I've tried to use publish-function in Visual Studio but I get "Publish failed".

Feb 24, 2010 6:46

Could you please try the follwing steps

1. Publis or copy the entire project folder in the loca drive(C:)
2. Create a IIS virtual directory and map the harddrive location.
3. check the startpage no in the web.config
4. Check what is the landing page in the iis settings
5. check the lincense of the episerver.

I think this will help you. Please let me know if you still facing the issue

Lakshmi narayanan





Feb 24, 2010 8:36


The pageStartID is 26 which is the correct id of the start page. I've set the IIS only to look for Default.aspx and I've replaced the license from the develop environment with the one that's tied to the IP-adress of the server. At first I forgot to do this but ended up with the same result with both of them.

Feb 24, 2010 8:44

I've tried pointing the IIS site to another folder containing another site and that site runs fine. I can reach pictures, html- and txt-files within the site but as soon as I come to a aspx-file, wether an EPiServer page or a page outside the EPiServer framework it returns a this white, blank page.

Feb 24, 2010 12:17

You can get this error sometimes when the connection to the database fails.

Feb 24, 2010 12:45

As far as I know the connection is correct. Can't see anything wrong with it.

Feb 24, 2010 12:51

This page lead me on to a solution to get the site up and running but there are some problems with the images and linking between pages. I started a new thread for it. 

Feb 24, 2010 15:53
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.