SaaS CMS has officially launched! Learn more now.

Cannot add gadget in Dashboard/Edit mode

Vote:
 

Hi,

I've a site running normally, but somehow it's suddenly saying error when trying to add new gadget. I've tried with all built-in gadget like version linst.

The exception return from application is

The Type 'EPiServer.Shell.Storage.ComponentData' needs to be remapped in the Dynamic Data Store, see the Errors collection for more information.
Remapping can be done by applying the EPiServer.Data.Dynamic.EPiServerDataStoreAttribute attribute to the type,
setting its AutomaticallyRemapStore property to true and ensuring the <episerver.dataStore><dataStore> autoRemapStores attribute in web.config is set to true (or is not defined).
Alternatively call the Upgrade-EPiRemapDDSTypes cmdlet from Powershell.

I try to query from database for store, but result is empty. I wonder if something cause this issue and clear all personalize setting. Anyone know how to reset this to default so it's work again?

All other function work normally, just can't add new gadget

#85262
Apr 22, 2014 5:12
Vote:
 

Hi!

I've not seen this error in production but I think we had a bug when developing. Have you upgraded your site from EPiServer 7 to 7.5?

#85273
Apr 22, 2014 8:56
Vote:
 

Hi Linus,

No, my site is built from 7.5 (7.5.394.2) and it's running normally. I can add/remove any gadget, build-in gadgets, our gadget without any problem previously.

But one day, when I try to add Version list gadget back and got error. We have same code base/database on other server and still work pretty well.

#85274
Edited, Apr 22, 2014 9:08
Vote:
 

Further down, I find out that the object was return from LocalCache and which is an error object. How could we clear LocalCache to force do remap is required?

#85399
Apr 24, 2014 13:25
Vote:
 

Hi again Dzung!

Unfortunately, I have no direct answer to this. If you can't resolve it I suggest that you open a support case for this.

Regards

Linus

#85432
Apr 25, 2014 8:36
Vote:
 

Thanks Linus.

 

I'm manage to fix it by manually get StoreDefinition for ComponentData and do remap it.

#85839
May 07, 2014 5:57
Vote:
 

For reference, we had exact same issue, here is the code that fixed this problem:

var storeDefinition = StoreDefinition.Get(DynamicDataStoreFactory.Instance.GetStoreNameForType(typeof(ComponentData)));

storeDefinition.Remap(typeof(ComponentData));

storeDefinition.CommitChanges();
#114338
Dec 10, 2014 12:49
Vote:
 

Hi Andrzej!

We have this error too, but where should we put your code sample? In what file?

#115291
Jan 13, 2015 11:28
Vote:
 

You should be able to put this code anywhere, just run it once and then remove it, as it will be no longer needed. 

#115295
Jan 13, 2015 12:28
Vote:
 

Thank you!

You saved my day :) It worked like a charm!

#115300
Jan 13, 2015 13:29
Vote:
 
#116090
Edited, Jan 23, 2015 3:31
Vote:
 

I'm so glad to see this help others :). It've been my headache for awhile

#116092
Jan 23, 2015 3:36
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.