Vulnerability in EPiServer.Forms

Try our conversational search powered by Generative AI!

After updating Episerver Find from version 12 to version 13, I cannot update the field in the index by id


Good afternoon. Faced the problem of updating the field in the find index after upgrading episerver find to version 13. It worked like that. There is a ContentData object for which is added to UnifiedSearch. An id is defined for it using `.IdIs (x => DocumentId.Create (x.Id))`. `IdAttribute` is added to the id field.Now when I try to update some field for this content, I get an error that the content does not exist in find. For this i use:

var id = SearchClient.Instance.Conventions.IdConvention.GetId({contentId});

SearchClient.Instance.Update<T>(id).Field(x => x.SomeField(), d.SomeField()).Execute();


"RemoteTransportException[Index][indices:data/write/update]]; nested: DocumentMissingException[[index][1] [SomeType][SomeId]: document missing]; "

This code worked fine on the previous version of episerver find (12.7.1). Help me please!

Apr 06, 2020 18:18

After upgrading, have you cleaned the find indexes and rebuild that?

Apr 07, 2020 4:59

Yes, index was cleaned and all content was reindexed

Apr 07, 2020 6:06

Can you try to index the property explicitly as suggested in following solution

Code sample

public class PageSearchInitialization : IInitializableModule
    public void Initialize(InitializationEngine context)
            .IncludeField(x => x.SomeField);

I am not sure you were already indexing that property or not.

Apr 07, 2020 7:56

Yes, I’m using this solution now, but it doesn’t work. But I noticed a feature that the custom models that we write to the index are updated by id, and everything regarding IContent does not work

Apr 07, 2020 14:22
Praful Jangid - Apr 07, 2020 14:31
OK, so do you have any direction now or can you provide more context about this id issue?
Artsiom Kalodka - Apr 16, 2020 13:16
What kind of additional information do you need?

@Praful Jangid What kind of additional information do you need?

Apr 21, 2020 13:00
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.