Try our conversational search powered by Generative AI!

Forms not working without store form submissions enabled


We have updated from CMS11 to 12.

in Forms on 11, it was possible to use a form with just emailing, without storing data. Now in latest version you need to enable "Store from submissions" else you get a displayed message "Form is not enable to store data" and disabled. Is this some kind of options to enable? or default behavior nowadays

Edited, Oct 19, 2023 19:11

Pretty sure is a bug, should work without storing, as that is what MA connectors do.

Oct 20, 2023 13:31

Strange, I just tried in a plan vanilla Episerver.CMS 12.23.0 with Episerver.Forms 5.7.0, with the following form settings:
Unchecked "Store form submissions", one emailing on submission, no webhooks, no MA.
Form is not disabled. I am able to submit the form, getting the default confirmation message. (no submissions are stored, obviously).

Oct 27, 2023 11:49

I have the same problem, when I disable "Store form submissions" I get the following error and "Submit" is disabled:
You cannot submit this form because an administrator has turned off data storage.

I have set up "Send email", allowed anonymous submission, disabled all custom forms related code. No errors in console either.

I have tested with Alloy and latest Episerver CMS and Forms nuget packages and do not get the error there.

The source code shows:
SubmittableStatus : {"submittable":false,"message":"You cannot submit this form because an administrator has turned off data storage."},

I have also commented out all security related response headers, to no avail.

Have you found any reason for this behaviour or a solution?

Nov 09, 2023 11:23

Found it after a while of trial and error.

We were not using Session and adding the following solved the issue:

services.AddSession(options =>
            options.IdleTimeout = TimeSpan.FromSeconds(10);
            options.Cookie.HttpOnly = true;
            options.Cookie.IsEssential = true;
Nov 09, 2023 12:47
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.