Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Unable to save a page in editmode

Vote:
 

Hi all,

Got some strange bahavior going on in edit mode.
On some clients toward some servers the clients are unable to save a page in editmode or switch from edit to preview.
All that happens is that the page refreshes but nothing happens.
I.e if you are editing a page and click save and publish, the page just reloads without taking you to the preview pane. No roundtrip to the server has been made. I susspect that something goes wrong in the EPiServer javascript code, there is no javascript errors though.

We have attached the IE 8 debuger and it does not toss any errors.

And even though a client browser has issues agains one site, it work just fine towards another !?!

We have tried to emty cache and everything short of a reinstall ;-)

So has anyone else experienced someting like this? Or got any ideas on how to get rid of it?
The server is CMS5 R2 SP2, although I do think we experieced it on SP1 as well.
We have seen this on IE 8, but our client has got this issue on IE 6 too.

Regards,
Morten 

#34911
Nov 20, 2009 9:51
Vote:
 

Does it refresh the page without doing a post?

What do the IIS log say?, does it register a post?

#34913
Nov 20, 2009 10:46
Vote:
 

Nope, nada gets back to the server. According to iis logs and Fiddler.
I failed to mention that when we are not able to do as save/publish,we are not able to navigate to the version list or back to the preview pane.
So as soon as one has clicked the Edit tab, it's imposible to navigate to either Preview, Version list or save, save and publish.
It is possible to switch to categories, the advanced tad etc.
In firefox it's possible to publish and shange views.

//Morten

#34919
Nov 20, 2009 13:16
Vote:
 

This was one though nugget to locate :-)
It was a Custom property that was rewritten from CMS4 to CMS5, but it was not missing an overload to the applychanges function(I beleve that was the prblem)

It did not toss any errors, warnings, javascript errors, nothing, nada, zip...so tought to find :-)
Solved now though :-)

Thanks from your input Anders.

//Morten

#34955
Nov 23, 2009 9:45
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.