Try our conversational search powered by Generative AI!

Indexing service not starting because of missing ObjectStore schemas


Having trouble with the Indexing service not being able to start properly at times. I seems like the ObjectStore types are not able to register because it's schemas hasn't been properly initialized.
This is normally solved through a restart of the service, but it keeps happening now and again which makes the Indexing unreliable. Has anyone had any similar problems or have any ideas of what could cause this issue?

Error message from the indexing service:
ERROR [7] EPiServer.IndexingService.ConfigurationHandler.RegisterTypes - Failed to register types. Will try later.
EPiServer.BaseLibrary.RepositoryException: Schema DefaultItem not registered.
   at EPiServer.Implementation.DefaultRepository.RegisterType(Type type, String schemaId)
   at EPiServer.IndexingService.ConfigurationHandler.RegisterTypes()

Dec 10, 2009 20:51

Hi Henrik.

I'm having the same problem.

Did you solve it?

Dec 15, 2010 16:11


I'm experiencing the exact same problem with the same error message.

Did anyone find a solution?


Aug 22, 2012 14:49
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.