Try our conversational search powered by Generative AI!

IE8 and xForm problem


When creating an xForm page in EPiServer CMS 5 R1 sp3 using IE8 it is not possible to send the form. Editing a previously working form will also cause it to stop working. Nothing happens when the button to send is clicked. Not 100% sure this is the issue but when creating a form on another similar computer running IE7 all works.

Is there anyone who has tried this and got it to work?

Mar 27, 2009 16:06


when CMS R1 SP3 was shipped IE8 was not released to the public and therefore this browser is not supported for CMS R1 SP3. You can try to run IE8 in compatibility view for such CMS installations (editing and administration modes).

We're going to post information on EPiServer World how to make edit mode (in older CMS versions) to make IE8 automatically fallback to compatibility view for all users.



Apr 03, 2009 9:03
Are there any updates on how to make older CMS versions compatible with IE8?
Apr 20, 2009 9:06

Eager to hear an answer as well. The editor can't even save the XForms, and activating Compatibility view for the site didn't seem to help.

May 18, 2009 15:43

Is there any solution for this íssue on EPiServer CMS R1 installations?

Jun 22, 2009 12:05

Hi There

 Has there been any more updates on this as alot of our clients are facing this problem even if they try editing the xform in compatibility mode.



Jun 24, 2009 15:29

This is what EPiServer said to me

 "IE8 is not supported for cms 4 and cms 5R1. I just tried xforms with IE8 and a cms 5R1 site and I got several problems. I also tried the compatibility view (IE7 mode) and I got issues there too. At the moment we don't have a hotfix and I don't know when there will come any. IE8 will work for cms R2."

Best Regards

Jun 24, 2009 15:38


we had the same problem with editing of XForms in IE8 within EPiServer 5R1 SP2.

Here is trick that will help you:

1) Open UI/JavaScript/xformedit.js and find next js function:

function formPopulateForSubmit( oForm )
 formContent.value = xFormControl.innerHTML;
 return true;

Instead of it type next js function:

function formPopulateForSubmit( oForm )
 var cnt = xFormControl.innerHTML;
 var regExpInput = new RegExp('<INPUT [^>]+>');
 var inputTemp = regExpInput.exec(cnt);
 while (inputTemp != null) {
        var regExpType = new RegExp('type=text|type=radio|type=checkbox|type=submit');
        var typeTemp = regExpType.exec(inputTemp[0]);
        var type = (typeTemp != null && typeTemp.length > 0) ? typeTemp[0] : '';
        var str = inputTemp[0].replace(type, '');
        if (type == 'type=text') {
            type = '';
            var regExpGuid = new RegExp(' {[a-zA-Z0-9]{8}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{4}-[a-zA-Z0-9]{12}}');
            var guidTemp = regExpGuid.exec(str);
            if (guidTemp != null && guidTemp.length > 0) {
                str = str.replace(guidTemp[0], '');
        } else if (typeTemp == 'type=submit') {
            var regExpOnCLick = new RegExp('onclick=[^\f\n\r\t\v]+');
            var onCLickTemp = regExpOnCLick.exec(str);
            if (onCLickTemp != null && onCLickTemp.length > 0) {
                str = str.replace(onCLickTemp[0], '');
                type = onCLickTemp[0] + type;
        str = str.replace('<INPUT', '<$MGL$ ' + type);
        cnt = cnt.replace(inputTemp[0], str);
        var inputTemp = regExpInput.exec(cnt);
 while (cnt.indexOf('<$MGL$') != -1) {
     cnt = cnt.replace('<$MGL$', '<INPUT');
 formContent.value = cnt;
 return true;

2) Now, If you have the problem with disappearing of form controls on every Save, Delete and Cancel actions during their update, open  UI/Edit/XFormFieldProperty.ascx file and find all button tags related to those actions ("Save", "Delete" and "Cancel" actions). There should be 15 cases. Replace button tag with adequate input field (the input field must contain type="button" and define the value attribute that displays "Save", "Delete" and "Cancel" text (use inner text of existent button tags for "value" attribute within new input field).

3) Clear IE cache (remove temporary internet files)

It should work.

Best Regards


Edited, Nov 24, 2009 13:46

I have worked out a solution for EPiServer 4.x and I'm pretty sure the problem is the same for CMS5 versions below R2. Read my blogpost here:


// Björn

Feb 13, 2010 18:31
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.