Try our conversational search powered by Generative AI!

Problem with creating EPiServer 6R2 project on Windows8



Windows 8 with 64-bit and x64-based processor, IIS8. It runs MS SQL server instances from versions 2012, 2008  and a default instance from sql2012. 

Ich have installed EPIServer 7 and 6R2 on the PC. There is no problem when I create an EPiServer7 project from the deployment center, but I get following error message during creating an EPiServer 6R2 from deplyment center:

Error - At C:\Program Files (x86)\EPiServer\Framework\\Install\System Scripts\Install Site (SqlServer).ps1:211 char:32
+ echo "Assembly redirect for $file:$fileVerssion"
+ ~~~~~~

At C:\Program Files (x86)\EPiServer\Framework\\Install\System Scripts\Install Site (SqlServer).ps1:211 char:32
+ echo "Assembly redirect for $file:$fileVerssion"
+ ~~~~~~
System.Management.Automation.ParentContainsErrorRecordException: At C:\Program Files (x86)\EPiServer\Framework\\Install\System Scripts\Install Site (SqlServer).ps1:211 char:32
+ echo "Assembly redirect for $file:$fileVerssion"
+ ~~~~~~
Variable reference is not valid. ':' was not followed by a valid variable name character. Consider using ${} to delimit the name.

Is EPiServer 6R2 incompatible with Windows8/IIS8? Is there some workaround for that. I tried to create on all three sql instances but the same error message.

Jan 16, 2013 15:58

I think it could have with different Powershell versions. Windows 8 has Powershell v3, while Windows7/Windows 2008 has Powershell v2.

Jan 16, 2013 17:06

What is workaround about that? It looks like that you have to forget EPiServer 6:-( 

Jan 16, 2013 19:47


I've got the same problem... running Windows 7, but PowerShell is in version 3.
( Installed IE10 some moths ago.. i guess PS3 was installed then.. ).

But still... is there a fix/workaround for this?

I found this:
it's possible to use 2 even if 3 is installed

powershell -version 2

will make current shell to run as version 2 -- BUT still... when restarting... it's back to 3 again... so, is it possible somehow to tell EPiServer Deployment Center to use -version 2 form CMS 6 in some way!?


Apr 12, 2013 9:40

I have the same issue when installing on Windows 2012

Apr 16, 2013 16:00
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.