Try our conversational search powered by Generative AI!

Dropdown values disappearing in episerver forms



We are having a weird bug on our Episerver site ( regarding Epi forms ( The site is hosted as an Azure Website.

We notice from time to time that the values in some of our dropdowns disappear. This seems to happen after we do a deploy, but not immediately after, rather after a while. A restart of the site (for ex. Touching web config) or re-publishing the item fixes the issue.

While we had the bug on our test instance, I tried going towards the same database from my local instance. When I did, I didn’t get the same error on my local instance (while still having it on the test instance). So it is possible that this is a bug/error at the application level. Does anyone know if Epi forms do any caching on these things, and if so how?

I have checked the logs and can see nothing regarding this.

Any hints appreciated, thanks in advance

Jan 13, 2017 9:58

We are facing similar issue. Currently in the middle of trace / debugging. Will post if anything popups.

Jan 25, 2017 8:08

We have a SupportCase report about this.

We will actively look into this immediatelly. Thank you.

Feb 06, 2017 4:11

Hi, this issue AFORM-955 is fixed and resolved.

We will release hotfix Forms 4.2.2 (on nuget feed) for customer who currently use 4.2.1 (when this issue was initially discovered).

It will be merged to Forms 4.4.1 and above.

Thank you.

Linked to

Edited, Feb 10, 2017 8:06
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.