SaaS CMS has officially launched! Learn more now.

EPiServer.Find.ServiceException: 401 Unauthorized - Just in localhost

Vote:
 

Hello all,

Yesterday, out of the blue, I started receiving errors when code that uses Find is called, but only in localhost:

EPiServer.Find.ServiceException: 'Response status code does not indicate success: 401 (Unauthorized). Unauthorized'

The same/similar error is reported in abundance when running the Search & Nav Indexing.

I have rolled back both code and database to try and solve this, but nothing.  I realize it's probably something with my local machine, but I don't know what changes would cause this behavior.

Any ideas/help is appreciated!

Thanks, Kevin

#319879
Apr 02, 2024 19:38
Vote:
 

Hi Kevin

What Search & Nav instance / license do you use? If your local solution is currently using developer demo license, it might be your license was expired. You can obtain a new one from Optimizely Find (episerver.com)

p.s. Developer demo license expired every 30 days

#319919
Apr 03, 2024 0:19
Vote:
 

Thanks for the response Vincent.  

I have used developer licenses in the past, but the one we have has been in use for maybe 11 months.  I'll contact support instead.

As a test, I did register a new developer demo license, and things are working now, so I think it is the correct answer.

#319927
Apr 03, 2024 14:10
Vote:
 

Hi Kevin

Glad to hear above helps for your troubleshooting. If you're using developer license, it should not be expired in theory. Good call to raise support ticket. 

#319982
Apr 03, 2024 23:18
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.