Try our conversational search powered by Generative AI!

EPiServer.VsIntegration.Package failing to install in Visual Studio.


I've been following the training module 'Introduction to Optimizely Education For Developers' and it indicates the folowing requirement for the Episerver CMS Visual Studio Extension ...

Episerver CMS Visual Studio 
Extension or later 
(includes EPiServer.CMS 11.15.1, 
EPiServer.CMS.UI 11.25.0)

I tried finding this in the Visual Studio Marketplace by doing a search on 'EpiServer but it does not exist.

So I instead did a google on it and found it in the market place website.

After downloading the extension I tried opening it with Visual Studio and the installation is failing with this output ...

5/24/2022 10:47:54 AM -     Supported Products : 
5/24/2022 10:47:54 AM -         Microsoft.VisualStudio.Pro
5/24/2022 10:47:54 AM -             Version : [14.0,17.0)
5/24/2022 10:47:54 AM -             ProductArchitecture : x86
5/24/2022 10:47:54 AM -         Microsoft.VisualStudio.Community
5/24/2022 10:47:54 AM -             Version : [14.0,17.0)
5/24/2022 10:47:54 AM -             ProductArchitecture : x86 

I'm running Microsoft Studio Community Edition 2022 and the above output looks like it is expecting version 14.0,17.0 which seems to be from about 2017.

The manifest in the package I downloaded is

Please advise on if there is a newer version of this package or if I should be using an older version of MS Visual Studio ??

If neither, please advise on next steps.

May 24, 2022 16:19

Seems that someone on my team ran into this and was required to install 2019 VS version.

May 24, 2022 16:34

Looks like I'm in business now.  This has been solved. 

May 24, 2022 16:56
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.