Try our conversational search powered by Generative AI!

Group name in Display attribute doesn't work


I'm not sure it happened after upgrade to final version, but GroupName in Display attribute doesn't work any more, when defining page programmatically.

For instance this field will be displayed under content tab:

[Display(Name = "Products",
Description = "Products",
GroupName = SystemTabNames.Settings,
Order = 50)]
public virtual PageReference Products { get; set; }


If correct tab is set in property settings in CMS, then it works, but I need it to work programmatically.

Any ideas?


Thank you.

Nov 22, 2012 17:45

I just tried it in our project and it works perfectly, I changed the GroupName and it created a new tab and I changed it back and the property was restored to the original tab.

Have you tried to click the button "Revert to default" on the pagetype, maybe that will help?

Nov 23, 2012 8:51

Philous, the same thing is happening for us, any properties that already exist and have values cannot be moved.

If you add a new property with the groupName of the tab it works fine.  I think this is a bug, anyone else seen this and can offer a work around?

Thanks, Paul

Mar 20, 2013 6:52

There is also a known bug (that was fixed in Patch 1) that makes all properties appear in the Content tab. I ran into this issue once, and also had to change it back using the property settings in CMS.

You might be running into this bug on your installation.

91301 Property's tab in a strong typed page typed auto change to "Content" after adding any page provider

Mar 20, 2013 15:28
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.