Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Unable to create shared blocks



I have a site upgraded from EPi 6. For some reason I am unable to create shared blocks. When I open the assets pane and choose blocks, the alternatives for creating new blocks and new folders are greyed out. At first I could not see the global blocks library folder either but I managed to find the correct id and set it on siteBlockFolderId in episerver.config. Now that folder shows but I am still not able to create any new folders or blocks in it. Does anybody know if this could be an issue with access rights for folders or some setting that I might have missed?

Jan 28, 2013 11:58

You should be able to see the access rights for the shared library folder if you go to admin mode and select Set Access rights. It is located as a children to RootPage.

Jan 28, 2013 12:56

I had the same problem but not upgrading from EPi6.

I fixed the roles for CmsAdmins and CmsEditors in EPiServerFramework.config and everything started to work correctly.

Jan 28, 2013 13:01

Thank you so much, I set the access rights and now it works perfectly!

Jan 28, 2013 13:50
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.