Try our conversational search powered by Generative AI!

Unable to see my custom add-ons in a local packagerepository



We have several add-on modules developed inhouse. We are currently installing the modules by "manual upload"

These modules are stored in a local NuGetServer, but we are not able to see the packages from EPIServer Add-ons manager

In Web.config I have added:

<episerver.packaging protectedVirtualPath="~/EPiServer/" >
<add name="MyNuGetServer" url="" />

In the nuspc file of the package I have added:

<tags>EPiServerModulePackage MyNuGetServer</tags>


I have used fiddler and EPIServer queries the service and reads the feed from the NuGet server.

My Add-on packages are in that feed.


Anyone knows what I how I can get my packages visible in Add-ons Manager ?

Apr 02, 2013 11:31

My guess is that add-on system decides that your add-on cannot be installed and that's why you don't see it in the UI. However, the same verification should be performed when you install the add-on using manual upload. So it sounds a bit strange if you can install the same packages manualy.

Could you enable the logging with debug level for add-on system and see how the system loads and verifies the packages? Add something like this in EPiServerLogging.config:

<?xml version="1.0" encoding="utf-8"?>

<appender name="outputDebugStringAppender" type="log4net.Appender.OutputDebugStringAppender" >
<layout type="log4net.Layout.PatternLayout">
<conversionPattern value="[%thread] %level %logger: %message%n" />

<logger name="EPiServer.Packaging" additivity="false">
<level value="Debug" />
<appender-ref ref="outputDebugStringAppender" />



Here I use DebugView tool, but you can log it to the file.

Apr 02, 2013 12:48


Sees like I had not verified that the package was installable. 

When I fixed the .net45 bug, everything worked as intended.

(earlier I teseted with a package generated manually on my locale machine and not on the build server)




Apr 02, 2013 13:27
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.