Try our conversational search powered by Generative AI!

Can't login to new allow MVC site...


I've tried installing CMO in a new Alloy MVC site.. I am facing an issue on that in that it now won't let me log on using my windows account? It's a fresh, new install, and the Windows provider is selected, and I am a local admin, so I see no reason why I should not be able to logon?? It worked when I setup a new site yesterday..

I followed these steps ->

I did the same yesterday, and I am certain I logged on with my windows username the without issue? Am I missing something silly here?

I've checked, and I am still in the Administrators group.

Jan 14, 2014 17:14

Have you tried all the following versions of your username:

* username
* username@domain
* domain\username

I've sometimes seen one of these fail (for reasons unknown to me)...

Jan 14, 2014 22:14

I've tried all combinations, with no luck...
Obviously tried rebooting my machine, again no luck

Below is the extract from my web.config file

    <roleManager enabled="true" defaultProvider="WindowsRoleProvider" cacheRolesInCookie="true">
        <add name="MultiplexingRoleProvider" type="EPiServer.Security.MultiplexingRoleProvider, EPiServer" provider1="SqlServerRoleProvider" provider2="WindowsRoleProvider" providerMap1="SqlServerMembershipProvider" providerMap2="WindowsMembershipProvider" />
        <add name="WindowsRoleProvider" applicationName="EPiServerSample" type="EPiServer.Security.WindowsRoleProvider, EPiServer" />
        <add name="SqlServerRoleProvider" connectionStringName="EPiServerDB" applicationName="EPiServerSample" type="System.Web.Security.SqlRoleProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" />
    <membership defaultProvider="WindowsMembershipProvider" userIsOnlineTimeWindow="10" hashAlgorithmType="HMACSHA512">
        <add name="MultiplexingMembershipProvider" type="EPiServer.Security.MultiplexingMembershipProvider, EPiServer" provider1="SqlServerMembershipProvider" provider2="WindowsMembershipProvider" />
        <add name="WindowsMembershipProvider" type="EPiServer.Security.WindowsMembershipProvider, EPiServer" deletePrefix="BUILTIN\" searchByEmail="true" />
        <add name="SqlServerMembershipProvider" type="System.Web.Security.SqlMembershipProvider, System.Web, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a" connectionStringName="EPiServerDB" requiresQuestionAndAnswer="false" applicationName="EPiServerSample" requiresUniqueEmail="true" passwordFormat="Hashed" maxInvalidPasswordAttempts="5" minRequiredPasswordLength="7" minRequiredNonalphanumericCharacters="0" passwordAttemptWindow="10" passwordStrengthRegularExpression="" />


Is there a script I can run to create a new SQL user in the database maybe?

Edited, Jan 15, 2014 9:33

Reading I think I have have lost connection to my Primary Domain Controller - It's letting me log on with cached creds.

I can't create a new user, as when I try and do so, I get the "The trust relationship between this workstation and the primary domain failed"...

Guess I need to get onto my IT support team to fix it.. 

Jan 15, 2014 10:22
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.