Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

500 error on reset index in EPiServer search

Vote:
 

Trying to get EPiServer Search to work and when I try to reset the index I get this error:

2014-03-17 15:49:19,692 [80] ERROR henrikf ACTIVE811 EPiServer.Search.RequestHandler.ResetIndex: Could not reset index '' for service uri 'http://localhost:37005/IndexingService/IndexingService.svc/reset/?namedindex=&accesskey=local'. Message: The remote server returned an error: (500) Internal Server Error.   at System.Net.HttpWebRequest.GetResponse()

If I go to the URL I get this error:

405 - HTTP verb used to access this page is not allowed.

The page you are looking for cannot be displayed because an invalid method (HTTP verb) was used to attempt access.

Anyone know What I might do wrong?

#82641
Mar 17, 2014 16:52
Vote:
 

This is a long shot. But by default services are only accessible with http POST and not GET. Try to add this setting http://stackoverflow.com/questions/618900/enable-asp-net-asmx-web-service-for-http-post-get-requests.

#82654
Mar 17, 2014 19:26
Vote:
 

After some more digging I found out that it was because it could not found the index with no name (namedindex=&).
I am trying to use the page:

/EPiServer/CMS/Admin/IndexContent.aspx

And it does not work even in the alloy-template so maby its something wrong with that one

#82678
Mar 18, 2014 10:01
Vote:
 

The default implementation is to not have any named indexes. Please see my answer here http://world.episerver.com/Modules/Forum/Pages/Thread.aspx?id=82617. And also make sure that the index exists in the app data folder and that the application has modify rights to the files.

#82721
Mar 18, 2014 18:24
Vote:
 

There are something mayor wrong with our indexing so we are redoing it from the scratch, se if that is working better. Will get back with info about that

#83028
Mar 25, 2014 7:51
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.