Try our conversational search powered by Generative AI!

Bug: JSON parsing of Link collection entries


Link collection presentation in the editor UI has changed between CMS 6 and CMS7, with CMS7 ajax requesting the data and displaying it in a pop-up.

Trouble is that CMS6 implementation allowed for the normal (straight) apostrophe/single quote character to be a value in the Link text, but CMS7 barfs on this when parsing the JSON response.

Easily demonsratable.  By creating and filling a link collection property and adding item that contains an apostrophe (') in CMS6 legacy edit mode. Then using CMS7 edit mode to try and open the link collection.  

I have not been able to find report of the same through the blogs, patch releases, or upgrade release notes.  We have not patched CMS7 because the 7.1 patch caused the editor UI to fail for IE users - which most clients used.  We rolled back.

Jun 19, 2014 4:33

I've tried this in EPiServer 7.5 and can't reproduce the error. I've also tried with both new and old edit interfaces in EPiServer 7 with edit UI 2.1.88 and can't reproduce the bug so I assume that is was fixed in the first UI update for EPiServer 7.

Jun 19, 2014 10:22
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.