Error - Office Add-in



i would  edit a document in file management.

I installed Office Add-in and i have all permissions.

When i click "Edit in Office" i get an error about DSOFILE module


Nov 30, 2009 13:36

I registered dsofile.dll and it works now.

From Microsoft:

"The Dsofile.dll files lets you edit Office document properties when you do not have Office installed "

But i had Office Installed :-\.

And also EPiserver Office Add-in :-\ :-\

Edited, Dec 01, 2009 9:30

I'm having the same problem. What do you mean by "regestering dsofile.dll". I tried to ad it to the GAC, but it didn't work.

Dec 15, 2009 17:02

Run "regsvr32 dsofile.dll"

Dec 15, 2009 17:18

Yes, use regsvr32.

It works.

But i am not satisfied. This means that i have to register dsofile.dll to each client/editor although they have office installed...

Dec 16, 2009 12:55

Yes, seems like that :-(

Also, I'm having trouble when publishing or checking in to an EPiServer-site. The problem is that I can't log in. The site says that i dont have enought privilegies.

Dec 16, 2009 13:06

I recommend that you install this update, place the files in C:\Program Files\EPiServer\CMS\[x.x.x.x] and reinstall the plugin:

Please let me know if this solves your problem!

Dec 16, 2009 14:04

On the server or local for each editor ?

Dec 16, 2009 15:11

On the server.

Dec 16, 2009 15:11

No luck. Installed the fix on the server. Reinstalled the plugin on the client. First i get a dialog where I have to login. Site-URL + username is set from the beginning and I need to fill in my password. This is the message I get when i try to check in a file (in swedish):

Anslutningen till den angivna EPiSever CMS-webbplatsen misslyckades, kontrollera så korrekt URL är angiven samt att du har rättigheter att utföra den här åtgärden. [200]

Dec 18, 2009 13:27

Found this in another thread:

<location path="<custom_ui_location>/OfficeIntegration">
            <allow users="*"/>

Now the authentication seems to work, but I get a new message: "Filen saknas på servern" (File is missing on the server)

Dec 18, 2009 14:04

Check if the filename/directory contains special characters

Dec 18, 2009 14:53

Yeeea!! It works, thanks a lot!

Dec 18, 2009 15:04

Anyone found out what to do with the DSOFILE error? I installed to update/hotfix on the server but still cant get it to work. Every time i try to edit a document from file management in Office i get the DSOFILE error.

Anyone got this to work without the client have to run the "regsvr32 dsofile.dll"?

Mar 23, 2010 10:32

There was an error with the installation package (msi) for the Office Integration where the dsofile.dll module wasn't properly registered. This problem only existed in the Office Integration msi package shipped with CMS 5 R2 SP2 and I'm fairly certain this is the problem you're running into when you get the "Fail to load dsofile.dll" error. The problem was fixed in the security update referenced above.

You need to deploy this update on the server and install the updated msi package on the clients. This is highly recommended, since previous versions was affected by the security problems referenced from the advisory page above.

Mar 23, 2010 15:04
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.