Try our conversational search powered by Generative AI!

Disable page in menu checkbox



Is there any way we can enable/disable display pages in menu option in admin/edit mode so that we can have certain pages mandatory in the menu?

Aug 20, 2009 14:13

You can set the default value of "display pages in menu" in admin mode, for each page type. You can also change access rights, to ensure that only people with Administer privileges gets to see/edit the "Advanced" tab where the option is placed (thats done in admin mode).

 Alternatively you could hook into the Publish event, and force the property to be set whenever a page that meets certain criterias is published - but that sounds a bit like overkill.



Sep 09, 2009 5:20

I am also facing the same problem of "Display page in menus" checkbox is disabled.

I am using EPIServer 6 with enterprise license.I have created main site with one startpage and subiste with another startpage.Now subsite's startpage is not visible in menu and in edit mode "Display page in menus" checkbox is disabled.In admin mode I have already set Startpage type of subsite with "Display page in menus" checkbox to true . Still subsite startpage is not getting displayed in main menu.Please assist.

Jun 29, 2011 9:24

The checkbox is only enabled on the master language for the page (that is the language the page first was created with). So if you switch to that language you can change the property.

The default value of a property is only used when a new page is created. It does not affect pages already created.


Jun 29, 2011 10:59

If you want to disable it for some pages look at this blog post

and just hide it, or make it disabled

Jun 29, 2011 12:16

Thanks Erik and Anders for quick help.Yes now its working.

Jun 30, 2011 7:38
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.