Try our conversational search powered by Generative AI!

XForm - Form select popup timeout?



When I try to select a form to be used on a specific page I get a timeout. FormSelect.aspx pops up but it takes forever to load all forms.

Sometimes I get the following error:

"Transaction (Process ID 56) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction"


Any hints on what to do or what could be wrong?


I'm running EPiServer CMS 5.2.375.133.



Jun 14, 2010 13:02

Yes I've had the same error sometimes. Same version of EPi. In my case its an old EPi installation that has been upgraded a couple of times with a couple of 100 xforms. It may take a minute or 2 before all forms have been loaded and I've gotten the same error as you have as well.

Using the reflector you can tell that the code runs 2 database calls for each XForm you have when opening the select page (even the ones that are not shown on the first page if you have more). Let's call it unoptimized code to be kind. I think the handling of xforms have been improved in the later versions so try an upgrade is probably your safest bet. Using the reflector and rewrite the XFormsSelect page like I did works too of course but not really best practice :)

Let me know if you find a good solution...

Jun 14, 2010 17:04


This is a known bug in EPiServer CMS R2 that is fixed in EPiServer CMS 6.

Linus Ekström
EPiServer Development Team

Jun 15, 2010 7:28

Thanks for replying!

Daniel Ovaska: If I come up with a solution I'll try to get back to you.

Linus Ekström: Ok...but isn't there an official hot-fix or workaround to resolve this? It should work in CMS 5 R2 and not require an upgrade to CMS 6.

Jun 15, 2010 8:39

Ahh, I knew that we had a fix for R2 but I did not know that it was release until now. Thank you Marcus for pointing that out.


Jun 15, 2010 8:43

So there is a hot-fix but it hasn't been released yet? Where can I find and download it?

Jun 15, 2010 8:45

Hi again!

It is available, though not publicly yet, so you have to start a support case to get hold of it.

Jun 15, 2010 8:53
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.