Don't miss out Virtual Happy Hour this Friday (April 26).

Try our conversational search powered by Generative AI!

Problem with sample UI workflow

Vote:
 

I have tried to get the SampleWorkflowsUI project to run. http://labs.episerver.com/en/Blogs/Johan-Bjornfot/Dates/112006/112115/EPiServer-Workflows/

 

I do however have a problem with the following.

. To the controls section on the pages configuration element add an entry for the WorkflowHistoryList user control, see example below where UILocation should be changed to the name of your UI folder.
<add tagPrefix="EPiServerWorkflow" tagName="History" src="~/UILocation/edit/WorkflowHistoryList.ascx" />

In the setup we are using the UI is placed in the default EPiServer installation location and linked with a virtual path. The path is defined in web.config 

<add name="UI" virtualPath="~/admui/" physicalPath="c:\Program Files (x86)\EPiServer\CMS\5.2.375.236\application\UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />
        <

<add name="UI" virtualPath="~/admui/" physicalPath="c:\Program Files (x86)\EPiServer\CMS\5.2.375.236\application\UI" type="EPiServer.Web.Hosting.VirtualPathNonUnifiedProvider,EPiServer" />

When I change the tag info in WorkflowApprovalStart.ascx to
<%@ Register tagPrefix="EPiServerWorkflow" tagName="History" src="~/admui/edit/WorkflowHistoryList.ascx" %>

Visual Studio 2008 wont compile and I get an error in the browser saying
Exception Details: System.Web.HttpException: Directory 'C:\...\Website\admui\edit' does not exist. Failed to start monitoring file changes.
It looks like it forgets to check the virtual path in web.config into consideration.

If I try to use the complete path
<%@ Register tagPrefix="EPiServerWorkflow" tagName="History" src="c:\Program Files (x86)\EPiServer\CMS\5.2.375.236\application\UI\Edit\WorkflowHistoryList.ascx" %>
I still cant compile and get an error in the browser saying "Parser Error Message: 'c:\Program Files (x86)\EPiServer\CMS\5.2.375.236\application\UI\Edit\WorkflowHistoryList.ascx' is not a valid virtual path."

I have tried moving the file "WorkflowHistoryList.ascx" to the folder itself and compiling with.
<%@ Register tagPrefix="EPiServerWorkflow" tagName="History" src="WorkflowHistoryList.ascx" %>
This compiles and the first UI is shown as intended the second however isnt and writes the following error in top. "Unknown server tag 'EPiServerWorkflow:History'" 

 

Anyone that have an idea what to do to fix it?

 

Best Regards

Simon Nielsen

#49182
Mar 08, 2011 13:40
Vote:
 

You could try to create a folder structure admui/edit under your physical site root and copy the file WorkflowHistoryList.ascx to the "local" admui/edit folder.

#49187
Mar 08, 2011 16:10
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.