SaaS CMS has officially launched! Learn more now.

Scheduler not working after upgrade from 5 -6

Vote:
 

Hi, after we upgraded a site from cms 5 to cms 6 there seems to be a problem with the scheduler. The service runs fine, but the jobs will not start. Manual start works fine. I have tried to recreate the sites.xml file, start and stop the service, but still the same problem. Any suggestions?

#45245
Nov 03, 2010 12:54
Vote:
 

From which version of 5 was the upgrade?

#45254
Nov 03, 2010 15:13
Vote:
 

hi,

The upgrade was from episerver 5R2. And the scheduler running is versjon 6.0.530.0. In the descripton of the service it says episerver 5, however in cms 6 i find references to 5 many places:) both the scheduler for episerver 5.2 and 6 lays in the the GAC.

#45284
Nov 04, 2010 10:03
Vote:
 

Try to delete the rows in the tblScheduledItem table for your EPiServer CMS instance.

When this is done restart the EPiServer CMS Scheduler Service.

#45634
Nov 11, 2010 13:10
Vote:
 

I've seen (I think) that a failing job prevents all other jobs from running afterwards. The jobs start running after a iisreset, but one of them fails, and from there out, no jobs are running. What jobs are you running? Any 3rd party or home-rolled?

See this for help troubleshooting the debugger:
http://www.epinova.no/blog/Tore-Gjerdrum/dates/2010/11/enable-debugging-in-episerver-scheduler/

/Steve

 

#45664
Nov 11, 2010 23:15
Vote:
 

Hi and thanks for the replies! I deleted every row in the tlbSheduledItem and tblScheduledItemLog, then activated only the jobs I know are used. There are no custom scheduled job, but Imagevault is installed and may have been cousing some funny behivior. Anyway, it it looks like the scheduler is running fine now! I'll keep a look at it for a couple of days and see if it stops by itself or if i enable more jobs to be executed! PS: Nice article about how to log the scheduler!

 

Fredrik

#45673
Nov 12, 2010 10:34
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.