Try our conversational search powered by Generative AI!

CMS 6 Upgrade udpTransport issue


After ugrading the site to CMS 6 the site runs ok. But after building the project in visual studio I got loads of messages from the different projects that reference to System.ServiceModel is needed. After adding the references i get this message when trying to access the webpage:

The type 'Microsoft.ServiceModel.Samples.UdpTransportElement, EPiServer.Events' registered for extension 'udpTransport' could not be loaded.

Pointing out this line in web.config:

<binding name="RemoteEventsBinding">
Line 854:          <binaryMessageEncoding />
Line 855:          <udpTransport multicast="True" />
Line 856:        </binding>
Line 857:      </customBinding>

<binding name="RemoteEventsBinding">
<binaryMessageEncoding />
<udpTransport multicast="True" />

What causes the error?

Jan 13, 2011 17:12

I have the same error.

Did you find a solution?


Mar 01, 2011 14:07

Same problem here, did you find a solution or still stuck? :)

May 13, 2011 10:42

Could it be that EPiServer.Events.dll is missing from the bin-folder?

May 13, 2011 12:09

Make sure the EPiServer.Events.dll file in the site's bin folder is the same one as in the {Program Files}\EPiServer\EPiServerFramework\\bin

May 13, 2011 14:33

This doesnt solve the problem. udpTransport is still marked as a faulty element in web.config. All dll files are the same in all folders.

We are now upgraded to CMS 6 R2 with the same issue. When trying to implement a servicereference it says the type:'Microsoft.ServiceModel.Samples.UdpTransportElement, EPiServer.Events' registrered for extension 'udpTransport' could not be loaded and it refers to the web.config line where the udpTrasport element is present...

Edited, Mar 27, 2012 13:38

I have the same problem. I were able to add a service reference a couple of weeks ago, but when I now try tu update it I get the exact same error as Nicklas. We use CMS 6 R2.

Jun 18, 2012 9:45

For the last two posts that refer to the same kind of error but inside Visual Studio rather than in the running web application, I would suggest something like the following.


Either just step around it by temporarily removing the udptransport related things from web.config while you add your service reference, or:


Check the assembly version of the appropriate EPiServer.Events.dll and ensure that this is available in the GAC.

Change the registration in web.config use a fully qualified assembly name so that VS can load it from the GAC, eg:

<add name="udpTransport" type="Microsoft.ServiceModel.Samples.UdpTransportElement, EPiServer.Events, Version=6.x.x.x, Culture=neutral, PublicKeyToken=8fe83dea738b45b7" />

(replace the version number with that applicable to your site)


Jun 18, 2012 11:49

I was having the same issue. I fixed it by adding a reference to the EPiServer.Events.dll which was already in my bin folder. I was then able to add service references without a problem.

Jun 19, 2012 18:39
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.