Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

TinyMCE editor text content invisible for some page templates in Firefox on Mac



A web editor for an EPiServer page we've developed reported an "interesting" bug yesterday.

When trying to edit a page, all rich text fields were shown without content (but when viewed, the content from these fields are displayed). She is also able to click the "HTML" button in the toolbar and see the raw HTML content of the field.

She experienced this using Firefox 11 on Mac, everything is working fine when she edits the same page in Safari. This only happens for rich text fields in a specific page template, not all rich text fields on all pages. There is nothing different in the definition of the rich text fields on this specific page compared to the page templates that are working as expected.

Has anyone else experienced similar problems?

Mar 22, 2012 11:19

Several of our clients are also reporting the exact same issue and we too are experiencing it ourselves.  This bug is not limited to a particular Page Type or property.  This bug was first reported to us on March 16th.


Any advice?

Mar 22, 2012 17:05

Was this related to R2, or to the recent Hotfix?  It seems a long time until report for this to be an R2 bug.

Mar 22, 2012 18:56

Deane might be onto something here. Can you both check what EPiServer.dll file version you have?




Mar 23, 2012 9:41


Mar 23, 2012 15:16

Seems to be a problem with TinyMCE and Firefox 11. So nothing do to with the general hotfix / updated R2 release.

There's a bug registered on it as well: Bug #77492: Multiple TinyMCE not working in FF11

The easiest workaround right now is to resize the textarea, and the text magically appears again! 

Mar 23, 2012 16:38

No, this is beyond just Firefox.  From the ticket my client opened with us:

"OK, so I get the proper editor in Windows XP on IE 8, but not when I'm on OS X Snow Leopard in Firefox 10, Safari 5 or Chrome."

So, every browser on Mac, it seems.

Mar 23, 2012 16:45

Maybe there are two different issues then, because the FF 11 issue is real. The TS also mentions it works on OS X if he uses Safari, so I would say that these are two different incidents

Mar 23, 2012 16:47

Our clients are also using 6.1.379.1.

We can confirm that this issue exists in FF11 consistently, but our clients are claiming this happens in other browsers as well.  We are experiencing the issue on Windows machines.  We are unable to consistently reproduce the issues in browsers that are not FF11.

From one of our clients:

"Starting on Friday, we have noticed that the edit mode on the CMS is not working properly. When you click on “Edit” the page loads, but you cannot see any of the content. It is there, as it can be viewed in the HTML. It can also be viewed by expanding the editing window.

(We) have encountered this problem using Firefox. I was just informed by one of my content authors that she was having the same problem in IE."

Mar 23, 2012 16:53

See this image:

It's everything on a Mac, it seems.

Mar 23, 2012 17:41

In FF11 I found that out of three XhtmlString-props on the same page the first two had the problem but the third one worked. Interesting is that those two had an alternate property setting (a lower height). When resizing the editor the text appears in that instance.

Mar 23, 2012 23:49

Just want to confirm that we are running 6.1.379.0 and that our user is experiencing this in Firefox 11 only (it works fine in  Safari and Chrome)., and that other web editors using Windows are not experiencing this problem at all.

Mar 24, 2012 12:57

Hi Deane,

Thank you for the picture, it really did clear some things up. You are actually experiencing another issue, which has to do with TinyMCE plugins. Do you have any custom TinyMCE plugins installed on the site? It works in IE right? 

Report this as an incident and we'll help you. 

The original problem is still just for F11 and will show no content. However resizing will show the content again and pressing the HTML mode button will show the html code.

Mar 26, 2012 8:39

One way to fix the FF11 problem is to force TinyMCE iframe to resize after load.
This is a small hack but this bug is really starting to annoy me. I added this script to CMS/Edit/EditPanel.aspx file and it seems to work on all of the pages I tested.

    $(window).load(function() {
    function forceTinyMceIframeResize() {
        $('.mceEditor .mceIframeContainer iframe').each(function(i)

Mar 27, 2012 18:22

This is definitly caused by an update of Firefox, we did not update our CMS and i am expierencing this problem also on: 6.0.318.113

Apr 13, 2012 11:41

The script solves the problem well if all the editors are on the same tab but if you have several tabs, one for the main body and one for the right column you get other problems. The tab loaded default works fine but when you change to the other tab the editors are minimized and must be manually pulled out to the right size. To solve the problem premanently TinyMCE version should be changed to a later version which doesn´t have these problems.

The only question is how does one do that in Episerver?

Apr 20, 2012 14:02



i'm not a epicenter user, but i've got the same problem with prestashop. By reading your comments, I've found a "solution". If you resize the firefox page content with the keys "Apple" + "+" or "Apple" + "-", tinymce works again. You can see and edit your content.

I hope that helps someone !

See you !


Apr 22, 2012 7:43

Seems to be working in FF12

Apr 25, 2012 13:41

I can also verify that it works in FF12.

Apr 27, 2012 10:23

I forgot to post back here that Tobias helped me resolve my issue -- the one of the WYSIWYG area not loading.  Inexplicably, if you remove "DisplayName" from the attribute, it suddenly works.  I have no answer for why this is so, but it's worked for two clients now.

Apr 27, 2012 21:20

if you change the above javascript to

    $(window).load(function() {
    function forceTinyMceIframeResize() {
        $('.mceLayout iframe').each(function(i)

    this seem to fix it for us. It works in all tabs.  Instead of altering the episerver files, I used a virtual mapping so this would leave episervers files in tact.

Edited, Apr 29, 2012 5:30
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.