EPiServer Social Reach: 503 error after installing



We're trying to install the EPiServer Social Reach plugin on our site, but are experiencing some difficulties.

First' we're getting the "duplicate entries in web.config" error for the "uri" section. After removing this from web.config for the EPiServer site, we're getting this error:

> The remote server returned an error: (503) Server Unavailable.
> Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.
> Exception Details: System.Net.WebException: The remote server returned an error: (503) Server Unavailable.
> Source Error:
> An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.
> Stack Trace:
> [WebException: The remote server returned an error: (503) Server Unavailable.]
> System.Net.HttpWebRequest.GetResponse() +7864708
> System.Xml.XmlDownloadManager.GetNonFileStream(Uri uri, ICredentials credentials, IWebProxy proxy, RequestCachePolicy cachePolicy) +160
> System.Xml.XmlUrlResolver.GetEntity(Uri absoluteUri, String role, Type ofObjectToReturn) +310
> System.Xml.XmlReaderSettings.CreateReader(String inputUri, XmlParserContext inputContext) +164
> System.Xml.Linq.XDocument.Load(String uri, LoadOptions options) +128
> <company>.Web.Util.RSS.ReadFromRSSUtil.LoadInternalFeed(String url, String language) in D:\projects\<company>\<company>.Web\Util\RSS\ReadFromRSSUtil.cs:110
> <company>.Web.Util.RSS.ReadFromRSSUtil.LoadFeeds(String[] feeds, String language) in D:\projects\<company>\<company>.Web\Util\RSS\ReadFromRSSUtil.cs:64
> <company>.Web.Default.Page_Load(Object sender, EventArgs e) in D:\projects\<company>\<company>.Web\Default.aspx.cs:84
> System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
> System.Web.UI.Control.LoadRecursive() +71
> System.Web.UI.Page.ProcessRequestMain(Boolean
> includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)
> +3064



Any input on this? Anyone experiencing the same issues?

When installing Social Reach locally, it works fine, but then repeating the steps on the test server is not working at all.. :-/


Jun 05, 2012 8:54


Is this for the Twitter channel?
I'm guessing your test environment is behind a firewall.
I had a similar problem and solved that by changing the settings in my twitteraccount for the "



Jun 05, 2012 9:53


No, this error occurs when accessing the frontpage of the website, before activating any channel or doing anything with EPiServer Social Reach (only installing it).



Jun 12, 2012 8:42


We had the same issue when we were installing Social Reach. It was solved by removing the following row from web.config:

<section name="uri" type="System.Configuration.UriSection, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089" />

It was caused by DotNetOpenAuth that added the line in web.config, but it already existed in machine.config (done by .NET 4.0).


Edited, Oct 25, 2012 9:35
This thread is locked and should be used for reference only. Please use the Episerver CMS 7 and earlier versions forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.