SaaS CMS has officially launched! Learn more now.

Install SQL Server database - Error


I have installed EPiServer Community successfully WITHOUT a database (Install site without database - EPiServer Deployment Center).

But when I try to install an SQL database I get the following error:

Error - Exception calling "GenerateUniqueValues" with "0" argument(s): "ServerName does not have a value"


And the Details:


An unhandled error has occured:

ServerName does not have a value

When executing


At C:\Program Files (x86)\EPiServer\Community\\Install\System Scripts\

Install Database (SqlServer).ps1:86 char:30

+ $wizard.GenerateUniqueValues( <<<< )Error - System.Management.Automation.MethodInvocationException: Exception calling "GenerateUniqueValues" with "0" argument(s): "ServerName does not have a value" ---> System.ApplicationException: ServerName does not have a value

at EPiServer.Install.SqlServer.SqlServerConnectionFactory.get_ConnectionString()

at EPiServer.Install.SqlServer.SqlServerConnectionFactory.CreateConnection()

at EPiServer.Install.SqlServer.SqlServerDiscovery.CreateDbConnection(String databaseName)

at EPiServer.Install.SqlServer.SqlServerDiscovery.DatabaseExists(String databaseName)

at EPiServer.Install.UI.Wizards.SqlServerWizardHelper.<>c__DisplayClass2.<get_UniqueNameEntries>b__0(String name)

at EPiServer.Install.Common.UniqueNaming.MakeNamesUnique(List`1 entries)

at EPiServer.Community.Install.Wizards.NewSqlServerDatabaseWizard.MakeValuesUnique()

at EPiServer.Install.UI.WizardBase.GenerateUniqueValues()

--- End of inner exception stack trace ---

at System.Management.Automation.DotNetAdapter.AuxiliarMethodInvoke(Object target, MethodBase method, Object[] arguments, MethodInformation methodInformation, Object[] originalArguments)

at System.Management.Automation.DotNetAdapter.MethodInvokeDotNet(String methodName, Object target, MethodBase[] methods, MethodInformation[] methodInformation, String[] methodDefinitions, Object[] arguments)

at System.Management.Automation.DotNetAdapter.MethodInvoke(PSMethod method, Object[] arguments)

at System.Management.Automation.Adapter.BaseMethodInvoke(PSMethod method, Object[] arguments)

at System.Management.Automation.PSMethod.Invoke(Object[] arguments)

at System.Management.Automation.ParserOps.CallMethod(Token token, Object target, String methodName, Object[] paramArray, Boolean callStatic, PSMethodInfo targetMethod, Object valueToSet)

at System.Management.Automation.Parser.MethodCallNode.InvokeMethod(Token NodeToken, Object originalResult, Boolean staticMember, Object[] paramArray, List`1 typeConstraint, PSMethodInfo& targetMethod)

at System.Management.Automation.Parser.MethodCallNode.Execute(Array input, Pipe outputPipe)

at System.Management.Automation.ParseTreeNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)

at System.Management.Automation.Parser.StatementListNode.Execute(Array input, Pipe outputPipe, ArrayList& resultList)



I have tried to find something about this on the forum and documentation but without any luck.

The DLL-files and EPiServerCommunity folder exists, and I tried to edit web.config adding a connectionString to a new database I created (just so it would point to something) but without any luck either.


Any help would be greatly appreciated!



Mar 24, 2009 12:03
This is a bug in the installer, that is solved now. The reason is that you don't have a SQLServer or SQKExpress on the server where you are doing the install.

Either you install a SQL Server (SQLExpress) or preferably you go to Programs and Features and uninstall the EPiServer Shared. Get the latest version of EPiServer CMS from Install only the EPiServerShared.msi by double clicking the file.

Best regards,
Tom Stenius

Mar 24, 2009 16:30
This thread is locked and should be used for reference only. Please use the Legacy add-ons forum to open new discussions.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.