Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

System Requirements for Relate 2 R2

These are the system requirements for EPiServer Relate The system requirements are described in relation to the general system requirements for the EPiServer platform, and any deviations from this or product specific requirements will be listed here.

Deviations or Specific Requirements for EPiServer Relate 2 R2

  • The Relate Templates are not adapted to WAI standards.

For other requirements, please refer to the requirements for the EPiServer platform as described in the following.

System Requirements for the EPiServer Platform

SERVER REQUIREMENTS

Operating system

Any of the following is required:

  • Microsoft Windows Server 2003 R2 SP2 32/64 bit
  • Microsoft Windows Server 2008 SP2 32/64 bit
  • Microsoft Windows Server 2008 R2 SP1

Web server

Any of the following must be installed as part of the Windows Server installation:

  • Microsoft Internet Information Services (IIS) 6.0
  • Microsoft Internet Information Services (IIS) 7.0
  • Microsoft Internet Information Services (IIS) 7.5 (see blog post for features)

Database

Any of the following is required:

  • Microsoft SQL Server 2005 SP2 32/64 bit
  • Microsoft SQL Server 2008 SP2 32/64 bit
  • Oracle 10g R2 32/64 bit (Windows server)
  • Oracle 11g 32/64 bit (Windows server)

Other requirements

Any of the following is required:

CLIENT REQUIREMENTS FOR EDITING

Operating system

Any of the following is required:

  • Microsoft Windows XP
  • Microsoft Windows Vista
  • Microsoft Windows 7
  • Mac OSX 10.6

Browser for editing

Any of the following is required:

  • Microsoft Internet Explorer 7.0
  • Microsoft Internet Explorer 8.0
  • Microsoft Internet Explorer 9.0
  • Firefox 3.6, 4.0

* Microsoft Internet Explorer (32 bit version) is required to use the drag and drop file upload and to publish from Microsoft Office to EPiServer CMS.

Microsoft Office Integration

Any of the following is required.

  • Microsoft Office 2003 SP3
  • Microsoft Office 2007 SP1
  • Microsoft Office 2010 - 32 bit only

CLIENT REQUIREMENTS FOR BROWSING

Browser for viewing

All major browsers are supported, including:

  • Microsoft Internet Explorer
  • Mozilla Firefox
  • Netscape
  • Google Chrome, Opera, Safari, Netscape

NOTE Browsers supported for viewing are entirely dependent on the construction of the EPiServer CMS templates.

Live Monitor

Requires Silverlight 3 or 4.

DEVELOPMENT AND DEMONSTRATION ENVIRONMENT

Operating system

Any of the following is required:

  • Microsoft Windows XP SP3 32 bit
  • Microsoft Windows Vista SP2 32/64 bit
  • Microsoft Windows 7 SP1 32/64 bit
  • Microsoft Windows Server 2003 SP2 32/64 bit
  • Microsoft Windows Server 2008 SP2 32/64 bit
  • Microsoft Windows Server 2008 R2

Development tool

  • Microsoft Visual Studio 2008 SP1
  • Microsoft Visual Studio 2010
  • Visual Web Developer 2008 Express Edition SP1
  • Visual Web Developer 2010 Express Edition

Database

Any of the following is required:

  • Microsoft SQL Server 2005 SP4
  • Microsoft SQL Server 2005 SP4 Express
  • Microsoft SQL Server 2008 SP2
  • Microsoft SQL Server 2008 SP2 Express
  • Oracle 10g R2 32/64 bit *
  • Oracle 11g 32/64 bit *
  • Oracle 10g R2 Express Edition *

* The EPiServer Visual Studio integration SDK installation requires Microsoft SQL Server Express.