Virtual Happy Hour this month, Jun 28, we'll be getting a sneak preview at our soon to launch SaaS CMS!

Try our conversational search powered by Generative AI!

Broken System Settings in 7.13.3?

Vote:
 

Hi,

After upgrading the Allow MVC Templates project to latest CMS version (7.13.3.0) and running the cmdlet 'update-epidatabase' to update to database, I cannot browse the Admin -> Settings Settings page. This worked perfectly before (v7.6 something) without changing any code or configuration on my own.

This is the stack trace of the error shown shown when clicking the System Settings in the menu:

[NullReferenceException: Object reference not set to an instance of an object.]
   EPiServer.UI.Admin.SettingsPage.SetControlValues(ControlCollection controls) +927
   EPiServer.UI.Admin.SettingsPage.OnLoad(EventArgs e) +119
   System.Web.UI.Control.LoadRecursive() +70
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3177


Turning on full logging in EPiServerLog.config doesn't reveal anything more. Any ideas to solve this???

#91269
Oct 01, 2014 11:36
Vote:
 

Aha, I kind of figured it out myself!

When looking into the content of EPiServer.Cms.Shell.UI.zip or EPiServer.Shell.UI.zip (under ~/modules/_protected/), I noticed there was a folder named "7.6.4.0", which led me to believe that those files under the _protected folder was not updated when updating the NuGet-packages. Bingo! The content of the "packages\EPiServer.CMS.UI.7.14.0\content\modules\_protected" folder, contained newer files. Manually replacing the files made it working again.

But I still wonder why this happened and was taken not taken care of by the nuget package? It seems that it succeded to copy the updated EPiServer.UI.dll to bin folder, but not the stuff going into modules folder. Could it a permissions problem, silently failing?

#91273
Oct 01, 2014 12:44
Vote:
 

For anyone else who find this thread after googling. Had the same problem today and struggled a bit before i got it working. I should mention that the CMS UI did not work and som other strange errors.

I've just upgraded from 7.5.394.2 to 8.5 and got the same error as anve in our testenviroment. The solution for me was to remove modules and modulesrepository under my vpp folder. Also make sure there is no mudulesbin under the root folder. 

#121271
May 06, 2015 8:30
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.