SaaS CMS has officially launched! Learn more now.

Changing attribute values and inheritance

Vote:
 

I have a base class with some properties with Display attributes. The base class is used by most classes in the project and have properties relating to html metadata. I want to change the name property of the attribute. If I change it and start the site the change does not appear in edit mode. Rather, the old name remains unchanged. If I change an attribut of a non-inherited C#-property the changes appear in edit mode. But for the inherited properties it doesn't show even if I edit the attribute name in the admin interface. The old name still sticks even though the new value appears in the "Edit property" view.

How do I resolve this?

#114100
Dec 04, 2014 13:28
Vote:
 

If you go into Admin | Content Types tab and select your page type and the property in question on the pagetype.

The User Interface Panel is where you should be able to update the Display name for the fields/properties ?

#114104
Dec 04, 2014 14:41
Vote:
 

I have updated the Display name in the admin panel, however nothing happens on the actual page. See the images below for some details:

Here we can see I have edited the images in the admin interface (Sorry about the swedish language setting)

Here I hover over the property I just changed, but it's name is still "Beskrivning" and it's description is still the old description, even though those should have changed to foo and bar respectively. I have the same issue when changing from code. The values stay the same. I don't want to change the property name in code, although I do believe that would fix it, because then the descriptions the users have already entered will be lost.

#114105
Edited, Dec 04, 2014 14:51
Vote:
 

Do you have ~/Resources/LanguageFiles ? containing PropertyNames.xml ?

Your properties may be defined in this file... look for an element with same name as your property containing a caption element.

You can try changing this value, or simply removing the language files ?

And I think recycling the site to be sure.

I see the test Alloy site has these language files and has defined metadata properties on the icontentdata type

#114113
Dec 04, 2014 15:26
Vote:
 

Thanks for your quick response, that solved my problem! I had an xml file that had the erroneous display names and description.

#114114
Dec 04, 2014 16:00
Vote:
 

No problem.

If it solved your problem, would you mind marking the post as the correct answer ?

#114145
Dec 05, 2014 9:02
Vote:
 

I would, but nothing happens when I click the "Mark as answer"-button...

#114147
Dec 05, 2014 9:11
Vote:
 

Yeah I have had trouble with that button myself :)

#114149
Dec 05, 2014 9:14
Vote:
 

The "mark as answer" problem should be fixed now. Please try again :-)

/Moderator

#114185
Dec 05, 2014 13:21
Vote:
 

Thank you! Works well now!

#114186
Dec 05, 2014 13:57
This topic was created over six months ago and has been resolved. If you have a similar question, please create a new topic and refer to this one.
* You are NOT allowed to include any hyperlinks in the post because your account hasn't associated to your company. User profile should be updated.